3

I just upgraded to ArcMap 10.6 from 10.3 and am running into this problem, and I'm seeing that all shapefiles (points, polygons both) disappear when I zoom closer than 1:7,000 and then reappear when I zoom out again. At first I thought it was just one shapefile, but it seems it's happening to all shapefiles and on multiple projects, including ones that were okay in 10.3. I tried:

  1. Making sure there's no scale-dependent visibility on individual layers;
  2. Clearing display cache;
  3. Deleting spatial index;
  4. Deleting .sbx and .sbn files for one of the shapefiles in question as suggested here (this caused the shapefile to fail to load); and
  5. Restarting and rebooting.

Nothing worked and most solutions are for when it's happening to just one layer (e.g. Points disappear when zooming in a certain scale), whereas for me it's everything.

Any ideas?

  • 1
    Have you tried backing up and then deleting the Normal.mxt? This sometimes fixes my Arc when it starts giving issues. Just rename it if you don't want to delete it. Make sure Arc is closed. Then reopen, the Normal.mxt will be regenerated. – Keagan Allan May 10 '18 at 21:27
  • Perhaps delete data frame and add layers to a new one. – FelixIP May 11 '18 at 1:46
  • That is quite a jump in versions it could also be a graphics card issue, have you updated the drivers for that? – Hornbydd May 11 '18 at 8:45
  • Thanks for the suggestions. Just tried deleting Normal.mxt, which did not work (thanks anyway @Keagan). I did just notice that the Roaming files for 10.3 are still in the file. Any reason not to delete those? (Old version is uninstalled.) – s_bklyn May 11 '18 at 14:44
  • @Felix I did try starting from scratch and no dice. – s_bklyn May 11 '18 at 14:45
1

Ended up getting help from ESRI on this. After recommending a complete reinstall, which did not fix it, here's what ended up working:

  1. Close out of ArcMap if it's open
  2. From start menu, go to: regedit > HKEY_CURRENT_USER > Software
  3. Rename ESRI directory to "ESRI_old"
  4. Restart ArcMap (the "ESRI" file will be recreated when the app loads)

That easy.

ESRI definitely wanted to first establish that it was not a data/layer-specific issue, so I'd still recommend starting with the actions I described in my original post (with the exception of #4, which caused problems for me). I also tried loading one of the shapefiles distributed by ESRI to make sure it wasn't something I was doing with my layers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.