-2

enter image description here

I am using QGIS 3.0 and attempting to intersect 2 block group layers with a common code value of '1'. I keep getting the following error for 2 of the 3 counties in my area of interest. I've tried using the vector buffer tool, the GRASS cleanup tool, the "check validity" tool, and the "fix geometry" tool, all with no luck.

Is this a Python bug? Any recommendations for other workarounds?

closed as unclear what you're asking by Vince, nmtoken, tinlyx, xunilk, aldo_tapia May 13 '18 at 0:12

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • did you filter the features with the value = 1 and tried to use the intersection? – hugonbg May 11 '18 at 15:49
  • Double-check to make sure that there are no empty rows in the attribute table. – MapHound May 11 '18 at 15:53
  • @hugonbg yes I did – Ashley May 11 '18 at 16:09
  • Maybe that's the problem, try to save only the selected features (right click on the shape -> save as > save only selected features) and then use the intersection. – hugonbg May 11 '18 at 16:13
  • 1
    @hugonbg that is exacty how I did it-sorry, thought you were using the term 'filter' in a more generalized way – Ashley May 11 '18 at 16:18
1

Update: I believe there are issues with the intersect algorithm , I used the GRASS vector overlay and it worked, after many failed attempts at other solutions

  • 1
    I spent twenty years creating what one of the developers referred to as a "chamber of horrors" for topology error detection and correction, but didn't have to submit any new defects in the last ten years of that run. While a new bug is possible, it's far more likely that the data really is corrupt. Esri Tech Support is the appropriate channel to resolve this. Next time, please provide the version of software involved. – Vince May 12 '18 at 2:34
  • Using QGIS 3.0, thanks for the advice. I wonder if the issue was due to having some blanks/zero out puts in my attribute table, as I explained @MapHound above.10 rows in the attribute table where the block groups recorded zeroes and blank spaces for some fields. For example, one block group has zeroes reported for the number of people in the labor force & the number of people unemployed in the labor force. The next field where I calculated the percentage of people unemployed in the labor force was = zero, so there is a blank there. Would this make my data "corrupt"? – Ashley May 12 '18 at 16:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.