1

I've just installed QGIS 2.18. I used the ltr version from from the advanced options of the OSGeo4W network installer. I went to set the folders where I keep my python scripts but when I click 'ok' I get the following error...

Has anyone had anything similar and know how to resolve?

An error has occurred while executing Python code: 

RuntimeError: maximum recursion depth exceeded in cmp 
Traceback (most recent call last):
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\gui\ProcessingToolbox.py", line 163, in updateProvider
    item.refresh()
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\gui\ProcessingToolbox.py", line 377, in refresh
    Processing.updateAlgsList()
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\core\Processing.py", line 184, in updateAlgsList
    Processing.reloadProvider(p.getName())
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\core\Processing.py", line 189, in reloadProvider
    algList.reloadProvider(providerName)
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\core\alglist.py", line 55, in reloadProvider
    p.loadAlgorithms()
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\core\AlgorithmProvider.py", line 56, in loadAlgorithms
    self._loadAlgorithms()
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\modeler\ModelerAlgorithmProvider.py", line 73, in _loadAlgorithms
    folders = ModelerUtils.modelsFolders()
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\modeler\ModelerUtils.py", line 46, in modelsFolders
    folder = ProcessingConfig.getSetting(ModelerUtils.MODELS_FOLDER)
  File "C:/OSGEO4~1/apps/qgis-ltr/./python/plugins\processing\core\ProcessingConfig.py", line 209, in getSetting
    if name in ProcessingConfig.settings.keys():
RuntimeError: maximum recursion depth exceeded in cmp


Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)] 
QGIS version: 2.18.19 Las Palmas, 3a17f72ba5 
1

It's a bug [1][2] in 2.18.19. You can can downgrade to a previous point release of 2.18, wait for the next point release 2.18.20 or manually make the changes to fix it yourself.

  • I am having a similar problem, when I want to save a simple user script in processing toolbox > scripts > user scripts, at some point I got a message like this: – nanunga Jun 10 '18 at 19:37
  • Like that, and now it freezes – nanunga Jun 10 '18 at 19:46
  • I have 2.18.20 and I have not yet attempted to downgrade, will be still be identified as qgis-ltr? because I had already configured eclipse and if it is not I think I will have to reconfigure it. – nanunga Jun 11 '18 at 1:45
  • Then I suggest asking a new question here or on the qgis-user list or submitting a bug report with the full exception traceback and description of your qgis install. – user2856 Jun 11 '18 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.