2

I tried to use Change Data Storage to change the bit depth of some rasters, but it doesn't work or gives me vague errors

I first tried to batch convert some rasters to unsigned 1 byte interger, I selected [1]unsigned 1 byte interger, 0 offset, scale of 1, load in QGIS? no, and obviously filled in the file names. It created some temp files for the calculations, but did not finish. It said "The following layers were not correctly generated. Converted Grid You can check the log messages to find more information about the execution of the algorithm"

I also tried to singly convert some rasters using the same tool and parameters. It created blank (no data) rasters, but did not give an error message

Anybody know the source of these errors?

8
  • Your QGIS 2.18.x is the latest version?
    – Kazuhito
    May 13 '18 at 5:13
  • It's 2.18.18. Unless I'm mistaken that's the last one they made before moving on to 3
    – Shane
    May 13 '18 at 5:56
  • I am mistaken. Looks like there's a 2.18.19 now
    – Shane
    May 13 '18 at 5:57
  • I'm downloading the newer version, but I suspect the problem is from user error and not a glitch in the program, so I'm not sure how much good that'll do...
    – Shane
    May 13 '18 at 6:03
  • Not sure which one work better in your environment, but could you try change data storage and convert data storage type?
    – Kazuhito
    May 13 '18 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.