0

My mouse no longer allows for panning using a click and hold of the center mouse wheel. I've tried a new mouse, in case that wheel was broken and no change. The scroll wheel zooms just fine.

Windows 10. QGIS 2.18.15 or QGIS 3.0.2, neither version works.

Any ideas what settings might have changed?

  • 1
    There's an option to pan the canvas by holding the space bar. – csk May 17 '18 at 19:08
1

Try going to Settings>Options and then click the Map Tools tab/section.

I believe that 2.18 had a control option (later removed in 3.0?) that allowed you to configure that. It would be in the Zooming or Panning and Zooming section and it was a dropdown menu called "Mouse wheel action."

1

I tried a third mouse after trying the original on another computer. It was the mouse, and the second mouse I used to test it. The third mouse works fine. Good to know about the space bar trick though!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.