1

yesterday my Windows 10 got update and finally, the Active X warning that has occurred for more than a year now vanished. Instead, I ran into another problem that never happened to me before and that might be due to the update I am guessing.

In ModelBuilder I built a model that generates a shapefile from some input data, runs through a number of analyses, and appends the fields of this shapefile to a master shapefile. Now, this tool works fine on its own. However, at the very end, it should delete the intermediate datasets that are created (namely the main shapefile that is later appended to the master). Every time the tool ends, the name of the file still shows up in ArcCatalog but it cannot be added to the TOC - it is broken. It is as if it was deleted "half" but not properly. In fact the file cannot be seen in The Windows File Explorer - and when I refresh the TOC view the file normally goes away.

This is not a huge problem until I iterate through the tool with different input data. The first run through always works fine, but once the second run starts, I get the error:

000871 : : Unable to delete the output .

As I said, I never had this before the latest Win10 update - so I am just wondering if anyone else ran into this (and found a solution to this?). I have not tried rolling back the Win10 update (in fact, I would not know how to do this either).

  • typical work-around for other "data not getting deleted by model builder correctly" problems has generally been to just add the "delete" geoprocessing tool at the end of the model and manually delete what needs to be deleted (use pre-conditions to ensure executes in correct order). Don't know if this will solve your "is half deleted" issue though. – John May 17 '18 at 20:29
  • Thanks for the reply - unfortunately that doesn't work. The "ghost" file still shows up. Maybe the problem is that I cannot delete "after" the append? Or at least I do not know how. The append uses the file but it also does not modify the file. So in the end there are two "arrows" going from the shapefile, one to the append, one to the delete. – Aaron Bufe May 17 '18 at 20:54
1

So the problem vanished after re-inserting the tool that was saving the dataset (it was raster to point), and leaving the save location to the default geo-database. I didn't try to dig in deeper in fear of it stopping to work again. Thanks for the help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.