I have eight DEM tiles that I downloaded from the USGS National Elevation Dataset. The individual rasters are displaying correctly, but when I try to combine them in a Raster Mosaic I get arbitrary values (3.4+038 -> -3.4+038), which is considered to be NoData.

I've tried several times, half the time I get a warning message upon creation of the Mosaic (001003: Datum Conflict) even though I was sure to match coordinate systems. I've even imported the coordinate system from one of the rasters going into the mosaic.

The mosaic shows the footprint of the DEM, but none of the data Mosaic

I had a similar problem here, but I followed the process of converting to tif before I tried to mosaic the images.

3 Answers 3


I ran into the same issue today, the following worked for me:

  1. Create raster mosaic dataset. Make sure to specify your pixel type. In my case, I specified 16 bit unsigned.
  2. In the "Add Raster to mosaic dataset" window check the "update overviews" box. Under "Advanced Options"
  3. Also from the advanced options, import your coordinate system. Make sure to select "Calculate Statistics" , "Build Raster Pyramids" and "Build Thumbnails"
  4. Finally, run a sample on 4 images, rather than your entire dataset, to make sure you get the results you want.

Good luck!


Calulate statistics on the raster.

You need the statistics to be able to apply stretches etc when displaying your new mosaic. The values you see are just the default max and min values possible for the pixel depth of your raster and not the actual range of the data within it. You will get the proper range once you compute statistcs.

  • 1
    It seems like that should be a default setting or at the very minimum not tucked away in the Add Rasters... option on the Mosaic Dataset.
    – Roy
    Jun 27, 2012 at 16:07
  • 1
    ...or better still an automatic process on creation of the raster... but then ESRI is quirky :) Jun 27, 2012 at 16:13
  • I jumped the gun there -- the Mosaic is still displaying those odd values even after calculating stats for all rasters and the raster mosaic.
    – Roy
    Jun 27, 2012 at 16:28
  • 2
    It could well be due to another ESRI quirk. This is, when ever you open a raster, ESRI will create RRD and AUX files. These are the pyramids and a pointer to the pyramid. It then uses these files to enable rapid display of the raster. BUT they sometimes persist even after computing statistics and similar operations meaning you are effectively displaying the wrong data even though you have updated it. Shut your MXD and hill both the RRD and AUX files for your mosaic. Then open it again (the RRD and AUX will be recreated - or you can tell ESRI to compute the pyramids manually). Jun 27, 2012 at 16:52

Thank you very much! I had exactly the same problem. I tried answer #2 and it worked! The key for me was specifying the pixel size in the mosaic (16 bit unsigned), re-importing the coordinate system and specifying thumbnails as well as statistics and pyrmaids. The problem is probably that the 32 bit DEMS are too large.

  • Welcome to GIS SE! Some of our protocols can take a little getting used to but in this case you seem to be using an Answer to comment upon an existing Answer. In such a case I would recommend adding a Comment to that Answer instead, or editing the Answer to improve it with additional details. However, you may need to accumulate reputation before either of those become options. Consequently, I will upvote here to try and assist you with that.
    – PolyGeo
    Feb 25, 2014 at 2:09
  • 1
    additionally "#2" isn't reliable, as the answer positions move depending on number of votes and accepted status. You can indicate a specific answer by using the [share] link at the bottom of each answer. Thanks for contributing to the list of what works! Apr 10, 2014 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.