I am new to QGIS and when I set up a new composer and add a map to the page nothing appears. I have pressed the render button and the up date with no results. When I print the map there is no map but the legend I added to the page is there.

I am using the latest version of GGIS on a MAC running Lion.

  • Have you checked that the extents are set correctly? Is the preview set to "Render" instead of "Rectangle"?
    – underdark
    Jun 27, 2012 at 17:36
  • Hi Thanks for getting back to me, I have set the preview to Render and checked the Set To Map Canvas Extent button, the coordinates look correct for my map and when I hit the update preview button -- no change, still a blank on the composer.
    – Andy
    Jun 30, 2012 at 23:02
  • Ok after much playing around I find that I can display a map in the composer with data from an imported text file but not with a shape file?? HELP
    – Andy
    Jul 1, 2012 at 17:41
  • Sorry but I've made hundreds of maps from Shapefiles and never met any such problem. Might well be Mac specific. Have you tried asking on the mailing list yet?
    – underdark
    Jul 1, 2012 at 17:47
  • 1
    Andy, can you please update me on what you did to solve your problem? I've looked everywhere and you are the only person I've found that has figured it out.
    – JHT
    Apr 11, 2013 at 20:20

1 Answer 1


I was running into this problem as well and the following worked for me:

Click "Add map" from the left hand side, then draw a rectangle on the canvas, and your map should appear.

  • Welcome to GIS.se! I think you'll find that the original poster did this step already ('add a map to the page') but found it wasn't rendering; that would have been QGIS 1.7 which had a lot of bugs.
    – Simbamangu
    May 31, 2014 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.