0

I have used the quick osm plugin to import the rivers in Germany.

enter image description here

I want to save the vector layer as a shapefile so I right click on the layer and go to save as... and save it as a shapefile layer

enter image description here

Once I click okay this error message appears

enter image description here

Any ideas?

  • 1
    Please post error messages in the body of the question as ASCII text. This allows others to search on your question. – Vince May 23 '18 at 0:45
  • 2
    Why was this question put on hold? It's clearly a GIS-specific question, not a general IT question. And I don't see any reason why other users won't encounter a similar issue when they try to save a layer with a longer name than the shapefile format allows. – csk May 24 '18 at 16:51
5

The error message mentions there is a problem with creating a field called "service_times"

Exclude this field from the export by un-ticking the box next to its name under the heading Select fields to export and their export options

enter image description here

5

The DBF format of the shapefile attribute table generally forces to cut the filed names after 10 characters. If you have fields service_time and service_times, this will create the error you got.

Changing the file type from shapefile to sqlite, geopackage or geojson solves your problem, and will preserve the original field names from OSM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.