0

There are 966 points for tree data that was collected in the field. When I try to open the attribute table only 2 points' data show up. I've tried to create layer from selected, because when I choose select all, it says:

966 out of 2 selected

But that hasn't worked, and I have also tried to export the data to Excel as well says transfer the file to a new map completely, nothing has worked. When I try to sort the points an error shows up. Is the layer just completely corrupt?

The original data was downloaded from ArcGIS Online as a file geodatabase. The data was collected with Trimble Catalyst receivers into a hosted feature layer on ArcGIS Online. All we are trying to do at this point is get the attribute table to copy over to Excel.

AttributeError

  • 1
    Welcome to GIS SE! As a new user please take the tour to learn about our focused Q&A format. What does the error message say? – Midavalo May 23 '18 at 15:27
  • 1
    Have you by chance had this attribute table open at all during an edit session? Suggest closing the attribute tables (all of them), saving the mxd, reopening, and open the Trees table first. See if that fixes anything. – MapHound May 23 '18 at 15:33
  • 1
    Thanks for the welcome Midavalo. I have tried reopening the mxd and going straight to the trees attribute table, @MapHound. It's weird because at a certain extent the actual symbology disappears even though fixed extent is off. – MF1995 May 23 '18 at 16:07
  • 1
    Has this file ever, since the download, given a proper attribute count or acted OK? Do you have a backup? Make sure this is not a data-driven map, as that will impose a hidden definition query, but I don't think that is what is happening. I have been encountering this lately in a file geodatabase, solved the problem mostly, but it is not pretty. – danak May 23 '18 at 17:03
  • 1
    Can you see points in ArcGis Online? – FelixIP May 23 '18 at 19:06
1

What appears to be happening is that the objectID index is corrupt, and this cannot be fixed directly.

Some or all data may be recoverable by using export to xml and reimport to xml options (harder but it worked for me) or by using the file geodatabase recovery tool (easier but it did not work well for me). You will be creating new files from your existing data. Both approaches will lose metadata and domains, relationships, etc. but it does not sound like the OP has this to worry about.

Even better would be to have a backup of all the raw data somewhere that could be reloaded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.