4

I have a point layer as control point in an atlas. I set map to be controlled by atlas, and there's only one option for point layer: fixed scale.

enter image description here

I render it, and every feature gets it's own scale, some of which are completely useless.

Is there a way to fix this thing?

QGIS version 2.18.19

Feature 1:

enter image description here

Feature 2: far away, barely usable

enter image description here

Feature 3: USELESS!!!

enter image description here

Every time same features get the same scale. These three are in the same city, impossible that WGS/Google projection has different scale there within 30 km.

What is going on?!

addition: Just to try, I added a field "sc" and pasted the correct scale there, and set scale in atlas to be used from this field. Did not help at all.

addition 2: just tried moving the map a little bit in composer, and scale changes by several times!

enter image description here enter image description here

4

Found out the reason: the project by default has no ellipsoid set, hence wrong sizes/distances.

Here's where you can fix it: set ellipsoid to WGS 84 (the one with a space).

enter image description here

1
  • Hmm this did not help in my case. Still only "fixed scale" is available (QGIS 3.10) – Jens Apr 27 '20 at 14:39
0

I solved the problem like this: In the composer select map layer. Under Main properties you can select Scale. Click on the icon on the right side and select Edit. Just tipe in the wanted scale.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.