0

enter image description hereWhen I use the geocoding tool to plot cities/states in the U.S. it plots only one point. However, the attribute table shows that all the points have been plotted. Furthermore, the one point is not accurately located on the OpenStreetMap (the point is in TX according to the attribute table when I select the feature, but it is visually located on Kansas). They are not plotted elsewhere when I zoom to layer (i.e. they are on the same CRS).

Attribute Table and Map (1117 points)

  • Make sure the CRS is the same as of the background map and not just a result of bad on-the-fly reprojection. – lynxlynxlynx May 24 '18 at 13:35
1

It look like the geocoding was unable to locate the adresses more accurately than as the country level so your point are all placed at the center of the country.

You should check that your adresses are correctly formatted regarding of your geocoding tool or try another geocoding tool

1

The file not in utf-8 but it is in utf-16 as it is seen in the error message. Unicode representation point to utf-16 encoding

Encoding    Representation (hexadecimal)
UTF-8[a]    EF BB BF
UTF-16 (BE) FE FF
UTF-32 (BE) 00 00 FE FF

as shown here, hence the tool is not recognizing the address

0

which QGIS tool were you using to do the geocoding and which QGIS version? I highly recommend using the long term release version of QGIS (currently 2.18) if you aren't already.

I haven't used a geocoding tool in GIS before and since I don't know which tool you used I can only give some general advice. I hope it will still be of use to you:

I did a little research online and found this website which also comes with a video tutorial. It uses the MMQGIS plugin (you can find this plugin under Plugins in QGIS and install it). I hope this tool and website will help you achieve your goal or if you have already used this tool, that the website can help you find the error.

Here is the link: https://www.gislounge.com/how-to-geocode-addresses-using-qgis/

  • I was using the 2.18 version and the MMQGIS geocoding plugin. I know how to use the plugin and have successfully plotted addresses before. For some reason, this is not working. Do you know if you can plot only cities/states in the U.S.? – Rachel May 29 '18 at 16:31
  • I just created a csv with four US cities and states and also used Tulsa, OK and New Waverly, TX so I would have some US cities the same as you. The other two were Orlando and Miami in Florida. It worked for me so I am very confused why it didn't for you. The points mmqgis generated were in the CRS with EPSG 4326 and OSM is in EPSG 3857. The on the fly projection made sure it was all correctly displayed and I even reprojected my points to 3857, then I turned off on the fly and found the 3857 in the correct place and the 4326 as expected in a different location. Maybe de- and re-install mmqgis? – Blue Sapphire May 30 '18 at 8:39
  • It isn't limited to the US of that I am sure as I have tried it with a city from outside the US and it worked as well. I hope my comments still help you even if it's only to rule out potential sources of error. I am sure you have checked this already but just in case you haven't make sure your CSV file is in UTF-8. – Blue Sapphire May 30 '18 at 9:08
  • File is definitely in UTF-8 but I do think there is an issue with the file, not QGIS. See this error (image attached) I get when I try to geocode new UTF-8 documents. – Rachel May 30 '18 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.