0

I installed geoserver software on my system as well as the JRE(Java Running Environment), but the geoserver admin through which I am supposed to log in appears as 'short cut', and more over if I start the server, it runs for some minutes and closes. I installed different versions of JRE as well as geoserver software but the same thing kept occurring. Please is there something am not doing right or omitting?

7
  • 2
    The admin web application is needed only for configuring the server. Services (WMS, WMTS, WFS, WCS) are running even you are logged out from the web admin tool. With the default installation you can test that for example with localhost:8080/geoserver/…
    – user30184
    May 25, 2018 at 10:20
  • 1
    Keep in mind that the admin "module" is a web page, not an executable, so it is ok to have a shortcut to the url.
    – JGH
    May 25, 2018 at 11:29
  • In this case, since my admin page appears to be short cut and cannot be used, which web address do I use to log in, moreover 'localhost:8080/geoserver/ is giving me error message.
    – IYKE
    May 25, 2018 at 15:37
  • What's the error message?
    – Ian Turton
    May 25, 2018 at 16:21
  • NOT FOUND 'The requested URL /geoserver/ was not found on this server.'
    – IYKE
    May 25, 2018 at 16:47

1 Answer 1

0

I had this same problem. I installed and uninstalled countless times.To solve this problem, uninstall the geoserver, then go to the directory where it was installed and delete the geoserver folder. Proceed by re-installation of geoserver. During the installation, change the port number. for me, I changed from 8080 to 8088. I equally selected the "Run as a service". I went to the "Geoserver Webadmin page" and launched it. It displayed an "Localhost has refused access" so i refreshed the page and check for reason. It indicated firewall was blocking. I refreshed the page the second time and it worked. However, if it does not work go to the Firewall settings and allow access for the local host.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.