1

I am not really confident with QGIS.

I am looking for at way to edit the attribute table of a shapefile, but the enable editing button is greyed out.

How do i fix it?

My end goal is to add a column to the file I have (which is a world map), so I can color code the world's nations according to their CO2e emissions.

I use QGIS 3.0.1.

Here's a photo of the attribute table:

enter image description here

And a photo of what it looks like without coloring the different attributes:

enter image description here

Also, here is the actual file: https://drive.google.com/file/d/1uftFMIc8AVLBWcyV_I5ryn0psw1Y80oM/view?usp=sharing

9
  • Did you try looking at this question: gis.stackexchange.com/questions/79957/… – cmrRose May 25 '18 at 18:26
  • you should give some more information about the origin of your shapefile ... – Snaileater May 25 '18 at 18:44
  • have you selected the layer in layers panel? – neogeomat May 25 '18 at 19:20
  • Hey guys, thanks for responding. Yes, I did select the layer in layers panel. I have attacked a photo of the attribute table if that helps. – Frederik Roland May 25 '18 at 19:33
  • 1
    @AndreSilva You're right - my editing workflow lapsed - the asker should now ping me and/or flag to get this question reviewed if they change their mind about it being solved and decide to revise it. – PolyGeo May 26 '18 at 20:13

Browse other questions tagged or ask your own question.