I have 16-bit satellite GeoTIFFs from DigitalGlobe (QuickBird/WV2), which I wish to share with a colleague that does not have access to GIS software.

When loaded into ArcMap, these sattelite images display fine and have a natural colour scheme.

When loaded into Photoshop, these rasters appear black and need manual stretching/editing/colour-balancing of the RGB bands to be visible. My end result is a raster with the wrong colours.

How does one export these 16bit satellite images from Arcmap, maintaining the colour balance/stretch applied by Arcmap, so it is possible to view in Photoshop and other non-GIS image editing software with the same display as in Arcmap?

Attempted solutions:

I have attempted two solutions (writing Arcmap's stretch to file by exporting the tiff and changing PS's settings to automatically stretch the tiff) with little luck..

1. Write the colour balance/stretch applied by Arcmap to file by exporting the tiffs, making the images visible in other software (Photoshop).

Unfortunately, when the tiffs are exported post-colour balancing and are loaded in PS they still appear black - meaning any colour balancing done in Arcmap does not display in the tiff file once exported to PS.

2. Replicate how ArcMap displays these rasters in Photoshop by changing photoshop's settings - so all images are automatically loaded into Photoshop with the same stretch / colour balance as in ArcMap.

I could only change the colour balance for each image, a tedious guesswork that led to images with the wrong hues of colour and contrast levels.

Note: I've tried GIMP, Ifranview, Photoshop etc and all image editing software displays these 16-bit GeoTIFFs as black. Only ArcMap automatically displays them in the correct colour balance. I need to give these images to someone without ArcGIS, so they need to be visible in PhotoShop, but I also need to retain the high-resolution of the original 16-bit TIFF format, so can't convert to another image format like JPEG.

  • Can you point to or link to one of these, or if they are large, create a cropped smaller version that shows the same behaviour? If not, can you run gdalinfo or show all the metadata you can get from one of the files?
    – Spacedman
    May 28, 2018 at 12:56
  • 1
    Your question isn't how ArcGIS displays them so much as how to make Photoshop display them the same way. This may cross out of GIS and into basic computer graphics. Please reformulate your question to meet our "One question per Question" policy, as stated in the Tour.
    – Vince
    May 28, 2018 at 13:07
  • Because ArcMap and Photoshop have different readings..Just any software they don't always have to be the same. So when you load any images to ArcMap or ERDAS, they have their own settings to load..so you would have to manually change the display settings.
    May 28, 2018 at 15:06
  • Perhaps if you could show us your images in ArcMap and Photoshop separate ...
    May 28, 2018 at 15:12
  • 1
    This sounds like more of a photoshop question than a GIS question. Try graphicdesign.stackexchange.com
    – Dowlers
    May 29, 2018 at 23:08

1 Answer 1


Photoshop, GIMP, etc. are not terribly well suited for working with geotiffs, as you have seen. What about, rather than having your colleague use image editing software, set them up with a free GIS software like QGIS? QGIS would allow them to work with the full 16-bit images and likely make it easier to match ArcGIS raster symbology settings (colour balance/stretch).

Alternatively, perhaps re-consider if it is necessary to maintain the full 16-bits of data for your non-GIS user. Only 8-bits/channel are visible at a given time anyway. In ArcGIS, changing the raster symbology (colour balance/stretch) doesn't affect the data, it only changes how it is displayed on screen (as you noted in the question). Part of displaying it to the screen is converting it to 8-bit values suitable for display. As such, when you select a pixel with the identify tool, it might report values like R=20761, G=16754, B=11412. But the display will be showing a pixel with 8-bit depth (e.g., R=239, G=236, B=198).

If the aim is for images that are visually identical to what appears in ArcGIS, and you can get away with 8-bit/channel data, use the 'Use Renderer' option when exporting raster data to apply the ArcGIS raster symbology to the output. They'll only be 8-bit/channel, but will appear in Photoshop or GIMP exactly how they look in ArcGIS.

  • Hi Dave. I tried using the Render option, however photoshop reports "an error parsing this file" when trying to open it? Jun 12, 2018 at 15:06
  • Also, would converting it to 8-bit from 16-bit via the render option cause the resolution of the image to decrease? (i.e would the 8bit ver be more pixelated when zoomed in than the original 16-bit). Jun 12, 2018 at 15:07
  • 8-bit vs 16-bit refers to the radiometric resolution of the image. Radiometric resolution is a measure of our ability to distinguish slight changes in brightness/colour. An 8-bit grey scale image can have 256 levels of grey between white and black. A 16-bit image can have 65536 levels of grey between white and black. The spatial resolution (i.e., pixel size) will not be affected by exporting from 16-bit to 8-bit; that is to say that no, the image will not be any more pixelated that the original. Regarding error you mentioned... I'll test an export here and get back to you.
    – Dave G
    Jun 12, 2018 at 15:36
  • 1
    From ArcGIS 10.5.1, and using the export data dialog (i.e., right click on the layer in the Table of Contents, and select Data > Export Data...), I just tried exporting a 16-bit Landsat image to an 8-bit TIF with the Use Renderer option selected. I don't have Photoshop; but GIMP opened it OK. I don't know what would trigger that error. Can you open the file you created again in ArcGIS successfully? Maybe try a different file format and/or compression. Check that the NoData value is between 0 and 255. It'll probably default to 65536, which is outside the 8-bit range.
    – Dave G
    Jun 12, 2018 at 15:53
  • Is it possible to perform the same in qgis? Dec 20, 2020 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.