2

This question already has an answer here:

I can create a point label with single size font (example)

enter image description here

However, I need to emphasize Japanese characters, make them larger in comparison to latin characters (example)

enter image description here

I tried some CASE WHEN expressions for Label -> Size option, but with no success.

Any hints (for QGIS version 2.18, alternatively v 3.x)?

marked as duplicate by JGH, Vince, user2856, BERA, Hornbydd May 29 '18 at 9:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

You can achieve what you want using Rule-Based Labeling, but you need to separate the Japanese labels and English Labels into two fields. Rule-Based Labeling option enables you to add labels from different fields and customize them as you like by changing font name, color, size and use offset to place them above each other as you can see below:

enter image description here

To do this:

  • Go to Layer properties -> Labels
  • Select Rule-Based Labeling

enter image description here

  • Define the fields that you want to use in the labeling, each one separately. In this example, I used Name_JP and Name_EN.
  • Use the style for each one independently and customize each one as you like.
  • The most important is to use Offset under Placement for the one of the labels so that they can be above each other. For the first label field I used the following placement settings:

enter image description here

For the second label field I used the following settings:

enter image description here

Tested on QGIS 3.0.1, But it can also applied in QGIS 2.18 because Rule-Based Labeling option is available.

  • Thank you for extensive answer @ahmadhanb. It is useful. Please, copy your message to the older question: gis.stackexchange.com/questions/48389/…, I will rate it there. The admin marked this post as a duplicate (so this post might be deleted). I implemented and maybe improved some steps. Especially I replaced Offset (which you do not have fully under control) by Data defined settings. – jurajb May 29 '18 at 8:09
  • @jurajb Thanks for your advice. I copied my answer and paste it in the duplicate question, although, I don't see it duplicate. – ahmadhanb May 29 '18 at 8:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.