4

In ArcGIS Pro 2.1, when I attempt to delete a field (via the attribute table, field view) or a feature class, my process fails and I get the following error message:

ERROR 000496: Table is being edited, failed to execute

but, the item I am working on is not being edited. The layer is checked off in the content pane and thus unchecked in the "list by editing". Yet, I keep getting this error message 000496 all the time. In ArcMap, we had the option of Stop Editing, but, this is no longer the case in ArcGIS Pro. The only way to stop editing is to uncheck the layer from Contents pane but this does not help me at all.

0
5

As @StephanoPotter commented, I closed the project, and reopened the same. Both deleting the layers from the Catalog pane and deleting fields from the attribute table worked well after the project reboot. I did not have to reboot the machine.

1

Although closing ArcGIS Pro will enable you to avoid ERROR 000496 upon restarting, like the answer from @TDS says, the correct way to do it may be to use the Edit tab of the ribbon to click the Save (Save Edits) button.

At this point all edits have been written and functions like deleting feature classes and fields should work again.

3
  • It is while since I had this issue-- as I can recall, saving as you mentioned did not help back them (2 yrs ago). But, I never had this problem recently.
    – TDS
    Jul 25 '20 at 18:38
  • @TDS I saw and could reproduce the same error message using the latest version (albeit a Beta). I plan to retest when 2.6 is released.
    – PolyGeo
    Jul 25 '20 at 21:08
  • CORRECTION to my previous comment: by "this problem" I was referring to the Save in Edit tab not helping to resolve ERROR 000496. In my recent work, saving the edits did help.
    – TDS
    Jul 25 '20 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.