2

I have my plugin which works for QGIS 2.8.2. I want to migrate the same for QGIS 3.0. I resolved initial error of pyqt4 to pyqt5 and so on.

Now I get following error for resources file.

TypeError: qRegisterResourceData(int, bytes, bytes, bytes): argument 2 has
 unexpected type 'str'

My existing resource file is compiled with pyrcc4 command. I need to compile it again with pyrcc5 command.

I went to my plugin folder from command prompt and did

pyrcc5 -o resources.py resources.qrc

'pyrcc5' is not recognized as an internal or external command,
operable program or batch file.

I have pyrcc5.bat in "C:\Program Files (x86)\QGIS 3.0\apps\Python36\Scripts" When I try to run this batch file I get:

enter image description here

pyrcc5.exe not found anywhere in the folder.