5

I am using QGIS 3.0.3 to make a heatmap using processing toolbox, kernel density estimation.

The input I am using: I have generated centroids from polygons using Vector --> geometry --> centroids tool in QGIS. I have saved the centroids in a separate shapefile. I use these files as an input, but it does not seem to work and I am receiving the following error message:

Traceback (most recent call last):
File "C:/PROGRA~1/QGIS3~1.0/apps/qgis/./python/plugins\processing\algs\qgis\Heatmap.py", line 213, in processAlgorithm
self.tr('Could not create destination layer'))
_core.QgsProcessingException: Could not create destination layer

Execution failed after 0.06 seconds

not sure what to do.

3
  • You need to add more information. What input paramaters do you use etc.
    – BERA
    May 31, 2018 at 7:11
  • 2
    I finally solved it. Probably there was some issues in the centroids shapefile generated by qGIS. This is what I did: 1) exported the centroids to CSV with XY geometry, 2) imported back the CSV to a shapefile. Then I simply ran the heatmap tool.
    – Lu76
    May 31, 2018 at 9:42
  • 1
    Please add the comment as an answer and accept it, so it future searches are easier. May 31, 2018 at 10:05

3 Answers 3

4

As indiciated here https://issues.qgis.org/issues/20105 the problem is most likely a lack of space.

I had the same problem and was able to solve it by reducing the radius and thus also the overall number of rows and columns.

The solution provided by Lu76 probably also reduced the necessary space. I tried it too and in one case it worked for me and in the others it didn't.

3

The solution provided in the comments did not work for me. However, I did find Damini Jain's answer in This post to work.

  1. Right click on your layer.
  2. Select Properties.
  3. In the Properties dialog, switch to the Symbology tab
  4. Select heatmap
1

I face the same warning during the georeferencing process "Could not create destination layer". Then, I unchecked the 'Set target resolution'. Tried to run it again and the georeferencing process works.

enter image description here

1
  • i clicked on transformation settings and removed (un-tick) the "set target resolution". it worked! Jan 28, 2023 at 0:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.