2

I have two shapefiles representing the same GPS track taken at different times. However, they have different coordinate systems so they do not match, they are separated by about 354 meters E/W. I would like to convert them to the same coordinate system so that they overlay each other. Both were exported directly from Trimble Pathfinder Office.

Shape1 has the CRS +proj=tmerc +lat_0=0 +lon_0=15 +k=0.9999 +x_0=5500000 +y_0=0 +ellps=bessel +units=m +no_defs

Shape2 has the CRS +proj=longlat +datum=WGS84 +no_defs

in QGIS I saved Shape2 to the CRS of Shape1, but it did not change its position. I also saved Shape1 to the CRS of Shape2, and it also did not change its position. In both cases the two shapefiles remained separate by about 354 meters.

  • What country is the data in? Germany? – mkennedy May 31 '18 at 17:48
  • Based on other question: If Croatia, layer may be using EPSG:3907 (MGI 1901 / Balkans zone 5), which would need a +towgs84 in its definition like +towgs84=551.7,162.9,467.9,6.04,1.96,-11.38,-4.82 – mkennedy May 31 '18 at 18:00
  • This is in Croatia. – sschultz May 31 '18 at 18:22
  • Thanks -- to clarify, are you saying I can't convert the Croatia datum to WGS 1984 unless the +towgs84 information is included in its CRS? – sschultz Jun 1 '18 at 6:04
1

mkennedy's comment above successfully solved this problem for me.

Here's what I did: I went to Settings -> Custom CRS and pasted

+x_0=5500000 +y_0=0 +ellps=bessel +towgs84=551.7,162.9,467.9,6.04,1.96,-11.38,-4.82 +units=m +no_defs

into the parameters box.

I then loaded the raster, chose the raster properties and set its CRS on the fly to the above custom datum, then set the Project CRS (lower right corner) to the same custom datum. Then I added the shapefile layers, and they were perfectly aligned with the raster, and with each other -- I did not have to do anything further. One shapefile was WGS 1984 and the other was MGI/Balkan zone 5. So all this was achieved on the fly, all I needed was the proper +towgs numbers that mkennedy provided above. Thanks all for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.