1

I have an Excel worksheet with USA zip codes, which need to be geocoded and displayed in ArcGIS Desktop 10.5.

First, I downloaded the "USA Zip Code Areas" layer from ArcGIS online and created a new address locator using the "US Address - ZIP 5-digit" style. Next, I imported the Excel worksheet into ArcGIS and geocoded the addresses.

The ArcGIS system completed the geocoding process but did not display any results on the map. A new layer of points gets added to the Table of Contents, which contains the expected data rows, but the points are not displayed on the map.

I have previously used ArcGIS Desktop 10.1 for the same problem with success.

EDIT 1: One difference between the two ArcGIS versions seems to be that the locator could be saved within the file geodatabase in 10.1 whereas it needs to be saved in a file folder (but outside the file geodatabase) in 10.5.

EDIT 2: The attribute table of the geocoded layer of points contains columns such as "Distance", "X", "Y", "DisplayX", and "DisplayY". All such columns have "0" as values for all rows. To further test, I added two new fields (i.e., Longitude and Latitude) and used the "Calculate Geometry" option, which resulted in NULL values for all rows. [As a comparison, I recall that ArcGIS 10.1 did not provide similar columns at least by default and also produced usable Longitude and Latitude values when "Calculate Geometry" was used.]

EDIT 3: I obtain the same results when saving the geocode result as a shapefile in a file folder or as a layer in a file geodatabase. When I search for a zip code using the Geocoding toolbar, the system seems to highlight (i.e., a green circle flashes in and out) the correct spot on the map! But the map does not display any symbol related to the geocoded point layer.

EDIT 4: An expert from ESRI has informed me that a patch/fix was released with ArcGIS Desktop 10.5.1 to address the problem described above. I haven't yet verified if 10.5.1 indeed solves the problem.

EDIT 5: It seems installing ArcGIS 10.5.1 would resolve the problem. I reviewed: ArcGIS 10.5.1 Fixed Issues and found the following entry:

BUG-000103072 Unable to return point output when geocoding with Zip 5, City State, State, and Zip+4 Range locators based on polygon reference data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.