2

I am identifying a catchment network from a DEM in QGIS3 (v3.0.3) (on a mac v10.13.4), however the step to identify the Catchment Area is not working.

I have an input DEM, with layer CRS set to UTM55S. I am using Method 0 (Deterministic). The output layer for the Catchment Area has no identifiable channel networks.

Catchment Area

I am using a hydrologically corrected DEM (provided by Geosciences Australia), clipped to the area of interest. I have saved the output raster in geotiff format and am working from this (could this be the problem?).

I am using SAGA processing toolbox.

I first run Fill Sinks, which gives an expected output - I check the difference between the original and Filled DEM and nothing stands out. I then run the Catchment Area using the default options and don't see what I expected.

Running the Channel Network algorithm is not giving me what I would expect - the network is entirely disconnected. I tried a few different initiation thresholds (greater than option - 0.1 -> 1e-6). These are subbasins of major rivers, I would expect to see a dominant stream network. Higher initial threashold

Close up of a much lower threshold

I have read a lot of different responses around this topic, but mostly they deal with wrong initiation thresholds (so blank output if too high), wrong projections (but UTM is suggested as appropriate), or CRS not being consistent (I have set CRS through Set Layer CRS to ensure this isn't the problem).

9
  • IMHO the catchment area by Deterministic 8 is not much appealing, since it limits possible flow directions. I like Deterministic infinity which probably gives you what you expect.
    – Kazuhito
    Jun 1, 2018 at 5:42
  • Thanks for the suggestion - I tried Deterministic Infinity and had the same problem.
    – Esme_
    Jun 3, 2018 at 23:18
  • I see. What I read from the first image is that the Catchment Area is too small (~0.00212) and even threshold value as small as 0.1 does not easily pick them up as streams. But threshold value itself is not the main issue here. Rather, your DEM would require more help (eg Flow Direction) to keep the flow. Can you share the link to the data?
    – Kazuhito
    Jun 4, 2018 at 2:03
  • The DEM is at drive.google.com/open?id=16jMha2unaq8yolz_F_yNLkNGmgM0A5Ah. I tried threshold values as low as 1e-6 with no luck.
    – Esme_
    Jun 4, 2018 at 2:49
  • Got that, Thanks! Firstly, the file you have (GA claims it is on UTM55S), is on geographycal (Latlon) WGS74. So the pixel size being (0.000277773,-0.000277789) causes problem in your work. You need to fix it by (1) Assign projection to EPSG:4322 then (2) Warp it to UTM55S (eg EPSG:32755).
    – Kazuhito
    Jun 4, 2018 at 3:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.