My ArcGIS 10.5 performance is very slow just in opening some thinks like: Options, tables, labels, arctoolbox, draw menu ect. It open the mentioned things in about 3 minutes. I have tried different solutions like: l deleted Normal.mxt, remove and reinstalled the ArcGIS, restore my PC and tried more solutions that I found in Internet but no one was useful to solve the problem. My Computer is Dell 5559 cori7 2.5GHz 4cpus, 8GB ram and 4GB Graphic dedicated memory This is bothering me. What is the problem?

  • 2
    If on a clean pc it's still slow, you may have to look at external influences. Do you access the data over a network? Is the database underperforming? Note that some actions are notoriously slow in ArcGIS, for instance, opening a certain menu for the first time may cause slowdown due to initialization. After that, it usually gets faster. I assume you already checked hardware acceleration (Customize → ArcMap options → Data View)? – Berend Jun 1 '18 at 6:42
  • For ArcGIS Desktop performance issues in general be sure to review our self-assembling FAQ on ArcGIS Desktop performance. How long does it take ArcMap to open in your configuration? Both the first time after a reboot, and subsequent times. – PolyGeo Jun 1 '18 at 6:46
  • 1
    Have you clicked Check your computer's ability to run ArcMap on the ArcGIS Desktop 10.5 System Requirements page? If so, did it pass everything? – PolyGeo Jun 1 '18 at 6:53
  • 1
    how big is your map project, how many featureclasses, and sources (local drives, servers) do you have there. It looks like a similar problem as my colleagues who is keeping all possible source of data in one map document doesn't matter if he needs it or not. Start jour project from scratch, add your data gradually checking the performance of your Arc... may help. – ChrisL Jun 1 '18 at 7:06
  • 1
    Other applications and virus checkers can influence performance, for example if you have BOINC running some distributed project that can slow things down. Also ArcMap indexing file stores is a bit of a killer so turn that off. – Hornbydd Jun 1 '18 at 13:21