I just installed ArcSDE 10.0 and ran the post install once to test the install and it ran great. Today I tried to run another post install to create another database and I get the error:

"Parameter "TEMP" not found in giomgr.defs file!"

This occurs in the repository setup. Has anyone had this same error or something similar? A point in the right direction would be great!

  • Does this actually cause repository set up to fail? This just sounds like a warning and not an error that would cause anything to fail. – Derek Swingley Oct 22 '10 at 22:54
  • It actually does cause the repository set up to fail. I'm unable to move on after this error. – Evan Oct 22 '10 at 23:03
  • Are there any other errors in log files in your %SDEHOME%\etc directory? – Derek Swingley Oct 22 '10 at 23:24
  • ever find an answer to your question? – SpoiledTechie.com Apr 23 '12 at 20:46

I'm surprised this is causing a failure but I would say edit your giomgr.defs file to add a TEMP paramter. More info on how to do this is in the giomgr.defs documentation.

| improve this answer | |
  • When I uncomment the Temp field in the giomgr.defs file it is still unsuccessful in the repository setup, but the wise_err is blank. Changing the Temp directory causes the same problem. I checked all the log files in the %SDEHOME%\etc directory and there was an authorization error once, but after running the authorization again the error is gone. – Evan Oct 26 '10 at 14:16
  • What has changed since you set up your first GDB? Are you running the PI as the same OS user? Do any objects get created in your new database (take a look with SQL Server Management Studio)? If you still can't figure this out, I would give support a call. – Derek Swingley Oct 26 '10 at 14:57
  • I am running the post install as the same OS user, but did find that the post install completes (but with the same warning during the repository setup) when I right-click and "run as administrator". My user is an administrator on the machine, but it seems Server 2008 64-bit has issues with this. Also, everything is created in SQL Server. I came across an ESRI Support forum (forums.esri.com/thread.asp?c=158&f=2290&t=298474) that touches on the same subject. I do believe I need to call tech support now. Thank you for your help. – Evan Oct 26 '10 at 20:13

I just wanted to describe a solution that worked for me with this error.

When setting up, make sure the SDE user you assign to your database has full ownership permissions to both the database and the master database.

This was sort of a fluke. I got so tired of trying to figure this one out, that I just made my SDE user have full rights to everything in the DB and after that, it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.