1

i created some number entry in QGIS modeler enter image description here

I created them specifically for them to be decimal numbers and not integer. enter image description here

But when i try my model, when i put a decimal number like 0.255 the value on the screen stays at 0. So it doesn't want to have decimal but just integer. enter image description here

Do someone has an idea ?

2

Set the Default value to 0.0.

Number parameter

This tells QGIS that the number parameter should be read as a decimal value. So when you run the model, you should see the decimal value in the input parameter:

Running model


Note: The Min/Max values can be left blank but will cause an error if they are filled with the string None. This occurs when you load the parameter settings again without setting those values.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.