1

I recently installed QGIS, GRASS, and SAGA-GIS-LTR onto a Manjaro (Arch Linux-based) system in order to make use of their newer libraries. While most of the software is working fine I did need to perform a workaround for GRASS to make use of the newest libraries such as GDAL (e.g. creating a symlink pointing to the newest version ln -s libgdal.so.13 libgdal.so.12).

Using the Arch User Repository, I installed SAGA-GIS-LTR and it seems to be recogized/callable from QGIS 3.0.2. Unfortunately, none of the algorithms have been working. SAGA will run the processes, signify that there's an output file and then crash without a stacktrace in the QGIS processing window.

I checked into it further and found that in my terminal the saga_cmd tools have a segfault and core dump on launch. The gdb (gnu debugger) stack trace is as follows:

   #####   ##   #####    ##
  ###     ###  ##       ###
   ###   # ## ##  #### # ##
    ### ##### ##    # #####
 ##### #   ##  ##### #   ##
____________________________

SAGA Version: 2.3.1


Program received signal SIGSEGV, Segmentation fault.
0x00007ffff6c491e6 in __strlen_sse2 () from /usr/lib/libc.so.6
(gdb) bt
#0  0x00007ffff6c491e6 in __strlen_sse2 () at /usr/lib/libc.so.6
#1  0x00007ffff6c619c4 in __mbsrtowcs_l () at /usr/lib/libc.so.6
#2  0x00007ffff7687b6f in wxMB2WC(wchar_t*, char const*, unsigned long) () 
at /usr/lib/libwx_baseu-3.0.so.0
#3  0x00007ffff7633b25 in wxMBConv::ToWChar(wchar_t*, unsigned long, char const*, unsigned long) const () at /usr/lib/libwx_baseu-3.0.so.0
#4  0x00007ffff76344b0 in wxMBConv::cMB2WC(char const*, unsigned long,unsigned long*) const () at /usr/lib/libwx_baseu-3.0.so.0
#5  0x00007ffff764402e in wxString::ConvertStr(char const*, unsigned long, wxMBConv const&) () at /usr/lib/libwx_baseu-3.0.so.0
#6  0x0000555555560b0d in wxString::ImplStr(char const*, wxMBConv const&) ()
#7  0x0000555555560c43 in wxString::wxString(char const*) ()
#8  0x00007ffff7a493cb in CSG_String::CSG_String(char const*) ()
at /usr/lib/libsaga_api-2.3.1.so
#9  0x00007fffe64b3cf4 in CPROJ4_Base::_Init_Projection(CSG_Parameters&) ()
at /usr/lib/saga/libpj_proj4.so
#10 0x00007fffe64ae9a5 in CPROJ4_Base::CPROJ4_Base(int, bool) ()
at /usr/lib/saga/libpj_proj4.so
#11 0x00007fffe64be02a in CPROJ4_Shapes::CPROJ4_Shapes(int, bool) ()
at /usr/lib/saga/libpj_proj4.so
#12 0x00007fffe647ce3b in Create_Module(int) () at /usr/lib/saga/libpj_proj4.so
#13 0x00007fffe647d27b in MLB_Initialize () at /usr/lib/saga/libpj_proj4.so
#14 0x00007ffff7ad7cc6 in CSG_Module_Library::CSG_Module_Library(CSG_String const&) () at /usr/lib/libsaga_api-2.3.1.so
#15 0x00007ffff7ad9e66 in CSG_Module_Library_Manager::Add_Library(wchar_t const*) () at /usr/lib/libsaga_api-2.3.1.so
#16 0x00007ffff7ada341 in CSG_Module_Library_Manager::Add_Directory(wchar_t const*, bool) () at /usr/lib/libsaga_api-2.3.1.so
#17 0x0000555555562e3a in  ()
#18 0x0000555555562f17 in  ()
#19 0x0000555555561e3c in  ()
#20 0x0000555555561cd3 in  ()
#21 0x00007ffff6bd506b in __libc_start_main () at /usr/lib/libc.so.6
#22 0x000055555555b17a in  ()

I'm wodnering where the issue is. Was SAGA-GIS-LTR not compiled properly? Am I missing specific libraries? Is this the result of a known bug?

1

It's a widespread issue with saga ltr on newer gcc compiler versions. It needs to be fixed by the saga team. There's no workaround that I'm aware of.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.