1

I'm running qgis 3.0.3 in Fedora 28 and I seem to have several, related problems with plugins.

Plugins --> Manage and Install Plugins: the window that opens shows 7 pre-installed plugins (I think there used to be 8 before, how come?).

Under the Settings tab, it says that "no python support detected, thus no settings available"

What dependency am I missing on my system?

Also, the search from the search field doesn't seem to work, it searches only through the 7 available plugins.

I downloaded a plugin from qgis and extracted it to

/home/myyser/.local/share/QGIS/QGIS3/profiles/default/python/plugins but it's not being loaded.

Any hints?

  • 1
    did you install qgis-python? – Ian Turton Jun 5 '18 at 16:28
  • Nope, not until now. This should be marked as a soft dependency by the package maintainer. Many thanks for your help! It now works as it should. – Flo Jun 5 '18 at 20:27
  • @Flo, please accept the answer if it works, so others can see that your issue was solved. – Chau Oct 3 '18 at 9:24
2

There is an optional qgis-python package that needs to be installed for the python plugins to work.

  • I am having a hard time finding this package. Do you happen to know where to get it? – AlexK Mar 19 at 0:23
-1

Try to find name of package python3-qgis in Fedora package manager (worked for me in Fedora 30).

New contributor
Petra is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.