0

I have two similar vector layers, with the same attributes. One is multipart and I used it as mask for the atlas, the other one is single parts and I want to use it to label the polygons inside each multipart polygon.

I have tried with the rule based labeling with this filter

within($geometry, @atlas_geometry)

But it only works sometimes.

enter image description here This works

enter image description here This one not.

I tried to check all the label condictions, and I tried to do it with centroids to ensure that the point was inside the polygon of the mask, but no way to make it work.

1

Try to use only the multipart vector layer to make your atlas AND for the representation.

In the layers properties you symbolise the vector on this rules-based:

$id = $atlasfeatureid

enter image description here

  • The problem is that the multipart layer have not the info I want to show in the label... I want to show the label of each part and that was combined when I created the multipart layer. – B RG Jun 7 '18 at 11:00
  • I think that i confused single and multiplepart. Have you tri this solution with single part? – Christophe Jun 7 '18 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.