I have re-used a single geometry layer and joined it with a lot of tables for regional maps of different variables. Now, I suddenly have an issue with labels for one of the polygons.The issue is apparent on layers saved in different locations, with different names and file types. And that are not re-used across QGIS projects. So essentially the layers (20+) that were not manipulated, re-used or interacted with in any way lost the labels for one particular polygon.

The issue randomly appeared, as I did the maps using one of the layers just a couple of hours before and labels rendered without any issues (I have the pdf - just can't share it due to privacy of the data). Now they are only rendered if you zoom in to the extent >1:250000 (see images). I have checked label rendering at different scales, it is disabled. The issue appears even if I load a month-old layer into an empty project and label using any of the columns.

I also don't have this issue if I open any of the layers in QGIS 2 (label renders). I have tried re-booting my system, loading any of the layers into an empty project, disabled all non-core plugins - nothing changes. The most bizarre/ludicrous thing is that even layers that were not touched for over a month now do not render the label for this one polygon in an empty project (they most definitely did in the past - I still have the pdfs). So is there some kind of "memory" in QGIS that remembers the geometry and translates it into use/processing of the layer that I can reset? I'm beyond certain that it's not an issue with the data for reasons mentioned above (different file types, file locations, layers not being re-used from one project to another).

At the required scale

enter image description here

1 Answer 1


Ok, I found a solution quite randomly trying to get that geometry layer re-created. It seems like due to unnecessary extra vertices (holes) in the polygon label was not rendering. I used "remove holes" algorithm with default settings and now everything works like a charm.

I tried using "Fix geometries" before, but that didn't have any effect. Now it's interesting to pinpoint a reason for the change, maybe when I was editing layer to change labels I accidentally moved a vertex and created a hole in the polygon? Although this does not explain why all other layers/files also had this issue appear suddenly (and why this did not affect rendering in QGIS 2?).

  • Unfortunately this solution isn't working for me. Was your issue occurring when you zoomed to the layers extent? Because my missing label shows when I zoom in or out, but not at the layers extent. This is the second time it has happened recently.
    – JohnGIS
    Sep 10, 2018 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.