I have been using Orfeo Toolbox with QGIS (version 2.18.0) to do image classification.

I was following this tutorial on YouTube on the SVM classifier. I have followed steps 1 and 2 as described, and obtained output. However, in step 3, my dialog box produces no output and the following message:

ERROR: Parameter -classifier.svm.m does not exist in the application. 
Converting outputs
Loading resulting layers
Algorithm TrainImagesClassifier (svm) finished

Now it appears to me that this particular part of Orfeo toolbox does not seem to be installed properly. Is that so? Is there a way to fix it?

I do not have administrative privileges on my PC and cannot use this method to install the toolbox. I have downloaded binaries from the orfeo toolbox website directly and supplied the path to that folder in QGIS. Does that not work?

  • 1
    What QGIS version? Is step 1 (compute image statistics) producing an output? Try going to Processing --> Options --> General --> Keep dialog open after running algorithm, and looking at the log there
    – 15Step
    Jun 12, 2018 at 10:22
  • @15Step I have modified the question with details after implementing your suggestions.
    – loudmummer
    Jun 12, 2018 at 11:16
  • I think the problem is mostly since the OTB version of the binaries you dled is not compatible with the QGIS version. How did you "supply the path" to QGIS?
    – 15Step
    Jun 12, 2018 at 17:55
  • I navigated to Processing --> Options --> Providers and copy-pasted the path in the "values" field.
    – loudmummer
    Jun 13, 2018 at 5:27

1 Answer 1


This is likely because you have a recent version of OTB but an older QGIS. Unfortunately QGIS-OTB compatibility is not great accross all version. We are working on improving this in OTB. In the meantime you can try:

  • Use a more recent QGIS (you may need admin rights on your computer)
  • Use OTB directly, outside of QGIS to do your classification, then load the results into QGIS normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.