0

When I was using Leaflet to display a tiled map images your answer was very useful,

This was what you answer that time: I only had to add the (-) and everything works good.

Just provide the "url" option instead of tileUrlFunction like: url: 'https://quadridcmmaps.blob.core.windows.net/tynset/{z}/{x}/{-y}.png'

I am using ArcGIS Online to add a Web Tiled Layer, and I am giving this address, but the images aren't displayed correctly, just like before, please help:

http://localhost/Mapas/2014/bing_roads_en/{level}/{col}/{row}.png

This is the result:

enter image description here

0

For ArcGIS Online you need to include the subdomain variables (i.e.'a,b,c,d'). So under the Subdomains space you will need to enter a,b,c,d, or a,b,c if that does not work. You will also need to alter the TMS URL to http://{subdomain}localhost/Mapas/2014/bing_roads_en/{level}/{col}/{row}.png.

  • I already try that, but I have the same result, I saw this video on Youtube: youtube.com/watch?v=UT4u0P6XTtI&t=87s, but it just dont work. – Johan Jun 13 '18 at 16:13
  • Are these tiles you've created and are hosting on a tile server or are they actually Bing tiles? – cbunn Jun 13 '18 at 19:31
  • I downloaded the tiles with SAS Planet and stored in a XAMP server with FileZilla, and they work fine with Leaflet for example, but not with Argis. – Johan Jun 14 '18 at 16:28
  • Why not just use the original source for the tiles in AGOL? – cbunn Jun 14 '18 at 16:35
  • Cause, I live in Cuba, and the Internet access is kinda limited, that the reason to the delay in my answers here, becouse we dont have online access all the time and when we have it, it is really slow, so I am trying to develop an offline app to people can use without internet access. – Johan Jun 15 '18 at 13:08
0

You do not need to add the subdomain, that parameter is optional and is only used for services that support it. For example, some tile providers have multiple subdomains to allow you to send requests to many servers to get faster responses. That's what it would be used for. I doubt your local server has that kind of setup, so don't worry about it.

Since you are hosting locally, your URL is currently http://localhost/Mapas/2014/bing_roads_en/{level}/{col}/{row}.png, and that looks right. One thing I'm wondering is if you set the extent when you added the layer?

In ArcGIS Online, go to Add - Add Layer from Web - and then select "A Tile Layer". Then put the URL you provided in the URL field. You have to populate the other 2 fields as you know. Then click "Set Tile Coverage" and accept the default (it should be the set to the whole world, essentially).

Please clear your browser cache or use a new incognito mode session while you are troubleshooting this, as otherwise, you might still see old, cached tiles.

I also noticed you are using the layer as a basemap - does it make any difference if you add it as a regular layer instead?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.