1

I am using windows 7, QGIS version 2.18.19. I tried the following standalone python script.

##Testing=name

drawingdxf=file

cleanf=output vector

outputs_GRASS7V_IN_DXF_1=processing.runalg('grass7:v.in.dxf',drawingdxf,'1',True,False,True,False,False,True,['200000.000000,700000.000000,200000.000000,700000.000000'],0,None) outputs_GRASS7V_CLEAN_1=processing.runalg('grass7:v.clean', outputs_GRASS7V_IN_DXF_1['output'],1,0.1,['200000.000000,700000.000000,200000.000000,700000.000000'],-1.0,0.0001,cleanf,None)

When I am running the program, following error was shown.

""NoneType' object has no attribute 'getitem See log for more detail"."

Can anyone help me solve this problem?

  • Replace the periods in the name with something else. E.g. outputs_GRASSV_IN_DXF_1 – Joseph Jun 13 '18 at 10:34
  • Thank you for your reply.I tried it,but still problem exist – Shanaka Herath Jun 13 '18 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.