2

I am using the vertex / node tool in QGIS 3.0.2 to move vertices in a line layer. Part of the new behaviour is confusing / annoying and I don't know if anyone can tell me how to change the relevant options. I have looked in the manual but it does not help - the behaviour is not described:

https://docs.qgis.org/testing/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html#id38

When I switch on this tool the cursor automatically highlights all lines that I pass. In all layers. Even if they are not visible. So if I have lines that overlap or a are close to the line of interest, the cursor switches to another line (even if it can't be seen on screen) and I need to move the cursor back to my target line in order for it to 'get focus'. This is REALLY annoying, especially as I have a vector contour layer in my project, so each hidden line gets focus even though the vertex tool doesn't actually change the vertex of a layer if it is not in edit mode (so that in itself is counter intuitive)...

There might be a good reason for this behaviour, but I'd like to switch it off and select features from only the layer I am currently trying to edit, as happened with the previous version of QGIS (2.18 for me). If it's a bug then I could report it, but I thought I would ask here first. Ah, another search of QGIS Issues has just revealed something - https://issues.qgis.org/issues/18434

It appears to be a 'feature' but maybe not all of us understand its benefits.

Please feel free to delete this post if moderators find it unhelpful, but when I'm looking for help this site is usually on the ball.

  • The vertex tool wil only switch to another layer if that other layer is editable and has the Vertex toggle button activated. To disable the vertex tool you have to toggle the edit layer button. – Jakob Jun 13 '18 at 15:22
  • 1
    Agreed, this is a terrible distraction - can't find any feature requests about turning this off either. – Simbamangu Jun 13 '18 at 15:42
  • Jakob - I don't think that is the case. On my version the cursor highlights hidden lines on layers that are not in edit mode - I can click on a vertex to move it (but obviously the change is not made as the layer is not in edit mode). I cannot see a vertex 'toggle' command (although I have toggle editing on the context menu) - please can you provide more information on that feature. – SeeWhy Jun 14 '18 at 16:30
  • @Jakob What version are you on? With 3.2.3 I still see the behavior described in this question (unlike in 2.x.x, where things worked like you descibe) – leo Oct 11 '18 at 8:15
  • @leo: 3.2.1-Bonn – Jakob Oct 11 '18 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.