I have a raster file and I want to perform the method "polygonize". Then the problem occurs, that is shown on the screenshot. It doesn t have anything to do with the rasterfile format, I veryfied. Other functions in the same menue(Raster->Conversion do not work either, because of the same problem). I m using the newest version of Qgis (1.8). Older threads here couldn t (as far as I saw) help either. So: I want to ask if anybody has an idea how to solve this problem? Thanks.

image of the error

  • What sort of raster is this? What does it show if you go Properties -> Metadata? Nick.
    – nhopton
    Jul 2, 2012 at 14:55
  • It s a .asc file (Arc Info/Ascii Grid) generated from interpolation. But it think it doesn t matter, because I double checked with a tiff.
    – Shepherdjo
    Jul 3, 2012 at 5:57
  • 1
    Of course it's aways possible that there might be a problem with your GDAL installation. But if what's shown in the picture is the raster you're trying to polygonize I think you have problems here as well. The polygonizer can only make polygons from areas having adjacent pixels of the same value and I think that even if you did manage to polygonize the raster you would probably end up with thousands of tiny, meaningless vector polygons.
    – nhopton
    Jul 3, 2012 at 7:58
  • 1
    Under the Raster menu you have the option to translate the raster DEM to any number or formats, including GeoTIFF, but this shouldn't be necessary. I don't know what you want to do with the DEM, but from under the Raster menu you could make contours from it, for example.
    – nhopton
    Jul 3, 2012 at 12:31
  • 1
    I seem to have the same problem (QGIS 1.8 running on Windows 7) I already did the following: + Checked not to have a PYTHONPATH system variable + Added "C:\PROGRA~2\Quantum GIS Lisboa\bin\" to the PATH variable + Also tried with "C:\PROGRA~2\Quantum GIS Lisboa\bin" and "C:\PROGRA~2\Quantum GIS Lisboa\" + Gdal was not installed separately + Installed Visual Basic 2010 Express. What else can be done?
    – Andres
    Nov 6, 2012 at 17:37

1 Answer 1


I'm not an expert in the compilation of QGIS (so will bow to greater knowledge and please treat this answer as a suggestion and not gospel), but I can think of two possible reasons for this error:

  1. If you have a separate instalation of GDAL for a different version of Python (especially Python 3.x) you will get similar errors and GDAL will not work in QGIS until you uninstall your other version of GDAL.
  2. You have a different version of Microsoft Visual Studio Runtime installed than the version used to compile the GDAL binaries for QGIS. I have both MSVC2008 and 2010 installed. Off-hand I can't remember what the QGIS folk used, so one of those should work. You can get the 2010 version here: http://www.microsoft.com/visualstudio/en-us/products/2010-editions/visual-basic-express and you'll find the 2008 version somewhere nearby. Simply install and then you probably will want to restart your computer.

Given that you can get even as far as you have without getting a Python version error (I get the Python error on start-up), I think the second option is more likely.

PS: BTW the latest version of QGIS is now 1.9 according to the last update I got from OSGEO4W... though the icon still says QGIS 1.8 confusingly enough.

  • Hello, thanks a lot for your detailed answer. 1.) Do you know where I can check the GDAL and python versions? I really hope this is the reason, because; 2.) Here at my work I have no admin rights to install new stuff, so I ll have to speak with the admins. But well, I ll do that if 1) doesn t work for me... I ll let you know if it worked then. Thanks for sure!
    – Shepherdjo
    Jul 3, 2012 at 6:05
  • The GDAL issue only occurs if you have separately installed GDAL apart from your QGIS install. Since you don't have admin rights, this doesn't seem likely. I THINK it is probably the MSVC issue TBH, but like I say, I am not an expert in this side of QGIS. Jul 3, 2012 at 7:52
  • 2
    Alright, Problem solved. Together with the admin here we figured out, that the problem occured because of a different version issue. I had to delete an old folder, that saved old settings and produced the error.So it was rather option 1) than 2) Your answer lead me to the solution and I hereby thank you for that.
    – Shepherdjo
    Jul 3, 2012 at 11:21
  • Happy to help and glad you got it sorted. Jul 3, 2012 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.