1

Missing attribute table! I'm using ArcMap 10.6. I have a shapefile of geo-political borders from Natural Earth. Both the shapefile and its attribute table are in working order. But after I join a csv to the shapefile, the attribute table of the shapefile completely disappears. I can't figure out where it's gone or how to recover it. There are absolutely no columns or rows (see photo). I know the join worked, because if I click/identify an individual polygon of the shapefile, I can see its attributes (new and old) using the identify tool; I can also see the fields in the properties > fields window, but no matter what I have tried, I cannot see anything in the attribute table of the shapefile after the join. The menus in the attribute table also are not working. However, if I remove the join, the attribute table of the shapefile once again appears as normal.

I tried exporting the data after the join, as another shapefile - to see if the attribute table would be visible there - but the export progress remains at 0% after several minutes...so I think that's not going to work.

How can I make the attribute table visible again after I do the join?

  • For now I pseudo-solved the problem by doing the Join in QGIS and exporting the shp so that I can view it and the attribute table in ArcMap. – natp Jun 18 '18 at 16:11
1

After loading the CSV file into ArcMap, export it to a stand-alone table within the geodatabase. Then set up the join using the table (instead of the CSV file).

  • I believe this solution works, much appreciated. Do you know why or how this works as opposed to joining the csv directly? – natp Jun 18 '18 at 16:24
  • 1
    ArcMap just seems to work better with tables within a geodatabase since it is the native environmment. When you export a CSV file (or Excel file) to a stand-alone table in the geodatabase, it creates an ObjectID. I've always had issues with CSV file and Excel files in ArcMap. – jpietsch Jun 18 '18 at 16:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.