I installed ZOO Project using the package installer (x64-72). To add MapServer, I installed ms4w using the zip file (ran apache-install.bat) and added the zoo project application. I also added the mapserverAddress pointing to the mapserv.exe on Apache in main.cfg of ZOO Project (running on IIS).

When I execute HelloPy or any other service with "useMapserver = true" in the services configuration file, I get the following error

ZOO Kernel failed to process your request, receiving signal 11 = SIGSEGV

Also, in the dataPath directory, two files, a .data file and a .zip file are added. If I pass in a shapefile's zip for HelloPy, the .data file shows some unreadable content while the .zip contains a .cst file, which in turn only shows some character encoding (ISO ... ).

Can someone please help me with this issue?

EDIT: I found that a part of my issue was that I was not passing in a file that could be understood by GDAL. On making this change I can see that the .map file is generated along with the two files mentioned above. However, the SIGSEVG error still exists.

EDIT 2: If I pass a WMS result to MapServer (say image/jpeg, image/geotiff) a mapfile is generated along with the other 2 files but the SIGSEGV error persists. If I pass in image/geotiff8 instead, then the result is a link for a getmap request. However, this link does not show any result.

If WFS results are passed in instead, like a kml, then the result is a vector map instead of the desired raster. What should I do?


What eventually worked was configuring MapServer to work on IIS by following this link. Then passing in data which was of KML type worked - it returns a GetMap request using the new mapfile it generates (for WPS 1.0.0 only).

However, the zoo-error.txt still shows the error

Unable to access the DataSource as ZIP File

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.