0

I have install on a Debian 9 a qgis-server, python-qgis, apache2 and libapache2-mod-fcgid. Apache service is runnning.

I have a folder uder usr/lib/cgi-bin/ but when I request http://localhost//cgi-bin/test/qgis_mapserv.fcgi?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities&MAP=projet_test.qgs

I have edited the conf file to enable fcgi.

Everything works on qgis-server 2.14 but not on qgis-server 3.

Any ideas?

1

What do you mean with "QGIS server 3 failed"?

To locate the origin of your problem, you should active error logs on different levels and post the outputs like:

  • Apache error logs
  • PostgreSQL error logs, in case your QGIS project uses layers from database
  • QGIS Server debug log following the docs

I remember a problem I had when migrating to QGIS Server 3 which was related to a missing PATH variable described in this issue.

To solve this issue on Debian and Ubuntu I had to add add the following lines to /etc/apache2/sites-available/qgis-server.conf:

# FIX path to library see https://issues.qgis.org/issues/18230
FcgidInitialEnv QGIS_PREFIX_PATH "/usr"
SetEnv QGIS_PREFIX_PATH "/usr"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.