1

I know it is an overasked question but I do not find anybody able to explain properly how to do that in SAGA 6.3.

The problem is that my shapefile, i.e. the borders of my country, do not overlap with the cities of the above country. I added the shapefile as a polygon and the cities as table then converted to points. Everything is plotted properly but there is a large vertical distance between cities and the country borders.

I had the same problem in QGIS and I solved it making the CSR consistent for the two layers. I am trying to the same here but with no success. Even if I change the CSR to EPSG 4326: WGS 84, they do not overlap.

What am I doing wrong?

  • To double-check the dataset (country and cities), can you start new project in QGIS and drag&drop each of the data (only one at a time) and see what projection and coordinates (x, y) are displayed on the status bar? – Kazuhito Jun 21 '18 at 11:54
  • @Kazuhito If I got what you asked, the coordinates are in the lat/long format for both the shapefile and the city coordinates. Instead, on SAGA, the shapefile has coordinates in UTM – PhDing Jun 21 '18 at 15:06
  • Thanks @Alessandro. It was a test to eliminate influence by On-the-fly projection in QGIS. Now it is clear that both data are set in Latlong (geographic), so it is quite a mystery why they do not fit well in SAGA. – Kazuhito Jun 21 '18 at 15:14
  • In SAGA the cities are in lat/long and I checked the coordinates are exactly those I imported from txt file. Shapefile instead has still x and y coordinates but with extremely high values, even negative so that they do not correspond to UTM either – PhDing Jun 21 '18 at 15:18
  • It's awkward... but then, you may consider reprojecting the layers by QGIS before exporting them to SAGA. Since Kriging does not work on latlong data, you will need to convert them anyway. – Kazuhito Jun 22 '18 at 9:12
1

SAGA 6.3 also offers series of reprojection tools. For a vector layer (e.g. Shapefile) Coordinate Transformation (Shapes) can be found in Tools | Projection | Proj.4 (or, from menu Geoprocessing > Projection > Coordinate Transformation (Shapes).

There are many options, but what you have to do is only:

  1. Select one of (1)Geographic Coordinate Systems or (1)Projected Coordinate Systems, and
  2. Select the layer you want to change CRS in the (2) >>Source area.

It is advisable to observe (3) EPSG code and (4) Proj4 parameters are correctly set, according to the CRS you have selected in (1).

enter image description here


(Another approach)

If you already know that one of your shapefile (either country or cities) has correct CRS, you can use it as a reference data.

Select the layer with correct CRS (1) Loaded Shapes. SAGA uses the CRS in (1) to reproject another layer (2). This is probably quickest way to match CRS between two sources.

enter image description here

  • Thank you for your suggestions. Anyway I am still not getting what expected. City coordinates have been collected manually from Wikipedia as latitude and longitude, while the shapefile comes from censusmosaic.org/data/historical-gis-files. What is strange is that in QGIS I got a perfect overlap doing exactly what I am doing in SAGA – PhDing Jun 21 '18 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.