1

I'm using QGIS 2.18.17

When I'm editing (e.g. removing objects) from a shapefile in QGIS and click to save the edits, all geometries are lost. All non-deleted objects are still present, but they do no longer contain a geometry (no objects visible in the layer and, when copying the objects from the attribute table in an Excel-document, the column "wkt_geom" is filled with NULL for all objects).

At first, I thought the problem only occurred with a point layer (shapefile), but today it also occurred with a polygon layer (shapefile).

The same thing occurred when I wanted to save a selection from a point layer as a new shapefile. The shapefile is created and the dbf-table is complete, but no geometries are present.

As I cannot imagine it concerns a bug in the used version of QGIS (as it is such a basic functionality), I assume the problem arises when saving the file with extension .shp (which stores the geometry) of the shapefile.

I'm working at a local government and the environment which I'm working on is a thin client (access through a Citrix viewer to a remote server) where a desktop environment is created which is identical for all users within the local government. All data is also stored on the same remote servers.

Anyone who had a similar problem in the past and found a way to solve it?

Edit: further investigation indicated that the cause eventually could be found in the way QGIS handles the network folders (on a Windows 2012 R2 Server), as the problem does not occur when writing on the local disk. Could it be something with some difference between relative and absolute paths? I already tried to switch this setting (without closing QGIS) but without result.

  • Did you try to split your geometries into single objects? Somehow sounds like you have multipoints/polygons. – Erik Jun 21 '18 at 12:33
  • No, it always consisted in individual points, no multipoints or polygons – Stijn Claes Jun 21 '18 at 13:35
  • 2
    Have you tried running a Check Validity (Processing tools) and/or Check Geometries (Vector menu) on your problem layers? – johns Jun 21 '18 at 13:46
  • Yes using the Check Geometry tool in QGIS, no problems were present – Stijn Claes Jun 21 '18 at 15:11
1

I had similar geometry issues due projection. Are your data projected? If not, project it to any reference system that you prefer and work with a defined projection.

  • All data are projected with EPSG 31370 – Stijn Claes Jun 21 '18 at 9:33
  • If your edits are only about deleting objects, maybe you can select the objects that you want from the original data and export them to a new shapefile. Or maybe the problem is where you are storing the data. Try to use a file geodatabase or the default geodatabase. Sometimes I just solved weird problems changing it. – Josep Pinyol Jun 21 '18 at 9:40
  • The export to a new shapefile results in the same problem. I know I could change e.g. to a Spatialite-layer, but this should anyhow be possible with shapefiles too. Furthermore, I need to have the data in shapefile-format later on for other uses. – Stijn Claes Jun 21 '18 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.