0

I'm trying to dissolve an hydrologic system because I have to many small portions for what I want to do but I can't figure how to make dissolve work ... the shapefile I'm using is a merge of different shapefiles (some I edited manually)

Here is how I set it up :

enter image description here

but when I execute it I get this message :

enter image description here

Do you know how I can fix this or if there is another way to reduce the number of entities in my attribute table? I have tried multipart to single part but it didn't reduce the number of items in my attribute table. Even having just one big entity could work ...

  • Your usage and goal don't seem compatible. If you check the "Make multipart features" it will actually dissolve all features into one (which is of course far too many parts for one feature). Please remember to always place the error message in the body of the question as ASCII text, so it is legible and searchable. – Vince Jun 21 '18 at 14:56
  • thank you for your answer. the error message says that the geometry has no Z value, do you kowe what that means and if there is a solution ? the rivers are not all connected to each other but they're made of smaller portions so I was hoping to find a way to join each of the smaller portions into bigger parts. You don't think it's something possible ? – tony-bof Jun 21 '18 at 17:50
  • Very wrong long name for output. Anyway check environment setting regarding Z and see if your input is polylines Z. – FelixIP Jun 21 '18 at 19:33
  • 1
    Please always provide any error messages as text rather than pictures. – PolyGeo Jun 21 '18 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.