4

I am using ArcGIS 10. I am trying to clip an NLCD layer from a vector polygon. I have used the Clip Raster tool in Data Management and Extract by Mask tool in Spatial Analyst among other things. My problem is that the processing completes without an error message but the image does not appear. I have zoomed to the layer and I have also checked in ArcCatalog.

2

My initial thought is that your spatial references needs to be synced. Try these troubleshooting ideas:

  1. In the table of content, right click your layer and select Properties > Source. Compare your two layers and make sure the spatial reference is the same. If they are the same, proceed to 2
  2. From the drop down menu, select Geoprocessing > Results > Current Session > Extract by Mask > Messages. These messages may help you troubleshoot the problem.
  3. If you get a message along the lines of "Warning: Empty Output Generated", try adjusting the environments by selecting Extract by Mask > Environments... > Processing Extent > Extent.

Also, check the properties of your clipped raster to see if there is actually any data associated with the raster. If all else fails, copy and paste the results onto your post--maybe folks will be able to assess the situation better. Best of luck!

2

Here is another method to try using the Raster Calculator, which you can find by searching in the Tools for "Raster calculator". In the Environmental Settings of the Raster Calculator, set up the following items:

  1. Processing Extent: same as your vector you are clipping to
  2. Snap raster - your NLCD raster
  3. Raster Analysis - same as your NLCD raster

enter image description here

Then do your clip in the Raster Calculator like so, putting your NLCD raster in the calculator input box (where mine has "NedOneNinthUTMMeters")

enter image description here

This should give you a new raster clipped to the vector polygon.

0

I had this problem, and tried all of the suggested fixes above. The only thing that worked for me was creating a .gdb to write the clip files to. Easy fix! Has to do with how they wrote the code for the tool...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.