8

I'm using: QGIS version 1.8.0-Lisboa on Windows XP, installed using OSGeo4W

I am behind a proxy but I have configured it in Options > Network.

When I go to Plugins > Fetch Python Plugins..

All of the the Repositories are "Status: Connected" however on the Plugins tab I can only see the 6 installed plugins (Repository: only locally available) - See images below:

Repositories Plugins

Any ideas why I cannot see any plugins from the "connected" repositories?

Many thanks.

Update - As suggested by vinayan I can install plugins by manually downloading them and putting them in the relevant folder and using the QGIS Plugin Manager. However still no joy using the Fetch Python Plugins.

  • I'm having exactly the same problem. The repositories say they are connected, but no plugins are listed. – Snorfalorpagus Jan 14 '13 at 11:26
  • same here-connected custom repository, via browser accessible, but unavailable plugins. Both methods don't work! – Ivan Myashkov Sep 11 '18 at 13:53
  • Hi Ivan. If you have a question that is not answered by this question, please ask a question. Answers are for answering questions. – HeikkiVesanto Sep 11 '18 at 13:55
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Mark Ireland Sep 11 '18 at 14:26
5

I am not sure i can solve your problem. But there has been problems fetching python plugins while behind a proxy. In your case, it seems only the dafault plugins are visible(displayed as "locally available").

If you check the repositories tab, everything will be shown as Unavailable(check "Status" field) as in the picture below.

Plugin Dialog

you can get the repo address by copying the urls from the picture above.

From there you can download your plugin and copy it to your python plugins folder. QGIS will then show your copied plugins in the plugins list.

Edit This could be a solution. It worked for me behind a proxy. In Qgis, Select Settings>Options.

Adjust Network as shown in below image. proxysettings

Credit for this finding goes to:@Alex Markov for this post

  • Sorry if I wasn't clear in my original post. On the repositories tab all of the 3rd party repositories do have a status of "connected". – Rob Jul 3 '12 at 10:36
  • @Rob - Have you set the Plugin Filter(plugins tab) to "All repositories" and "Any Status"? – vinayan Jul 3 '12 at 10:46
  • Yes, see updated post with images. – Rob Jul 3 '12 at 10:48
  • @Rob - check updated answer – vinayan Jul 3 '12 at 11:12
  • Unfortunately changing the proxy settings now makes the repositories' statuses change to "unavailable". – Rob Jul 3 '12 at 11:18
1

I had the same problem and this was due to the LAN setting of my connection. I checked this in my computer through "Internet Options --> Connections--> LAN setting" and under the LAN setting the internet connection was set to use a proxy server with address form xx-xxx-x-xx and port 8080. Then in Qgis, I Selected Settings-->Options and adjusted the Network as shown in below image. enter image description here

-2

Please try proxy settings Please try proxy settings

Please try this

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Welcome to GIS SE! A good answer should include information as to how to do what you are suggesting, and an explanation about what it does and how it answers the question. Please edit your answer to expand it with explanation. – Midavalo Mar 25 '17 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.