2

I am trying to create point features in a template geodatabase. I am adding the features to a feature class in an edit session. When I save the edits all of the features I just created disappear and there are no attributes in the attribute table for that feature class.

I checked the properties, and the feature class I am editing has no extent but it is in a geographic coordinate system and the data frame is projected.

Could this be the problem and if so how do i fix it?

7
  • Have you got a definition query in your layer properties? What storage type is your template geodatabase? (personal, file, enterprise) Jun 26 '18 at 0:17
  • The template is a file geodatabase. No definition query.
    – McMatt
    Jun 26 '18 at 1:07
  • Are you editing outside the domain of the feature class? When you say it has no extent what is in the domain (ArcCatalog properties, Domain, Resolution and Tolerance tab), what's in the Feature Extent tab?. Jun 26 '18 at 1:27
  • The feature extent tab for the feature class in question is all zeros. In my template, all the feature classes without extents have no features in them yet. The feature classes that have extents have features that I usually add through GPS data that I collect. There is a domain in the domain, resolution, and tolerance tab that is the same as my other feature classes.
    – McMatt
    Jun 26 '18 at 11:14
  • 1
    Guess what? Because the feature I was trying to add was a multipoint feature I had to double click. Wow. Thanks for your help. I can't believe I overlooked that!
    – McMatt
    Jun 26 '18 at 11:48
1

I had a similar issue with my edits disappearing after I selected "Save Edits" in the editor toolbar. The fix I found was as follows: before I selected "Save Edits" I exposed the context menu (by right-clicking inside of the data frame) and selecting "Finish Sketch". After I selected finish sketch, I could save my edits without the newly created points disappearing. Hope this helps.

1
  • The answer provided by tassones worked for me. Too bad I lost an hour worth of work.
    – Louis
    Nov 5 '20 at 22:46
1

I have figured out the cause of this issue (at least for my case). I found that @tassones answer about using the "Finish Sketch" command worked, but it got me wondering why does ArcMap think that this sketch is unfinished? It is just a point after all and simply placing it on the map should finish it (it usually does work this way).

So I double-checked, and found that it was actually a MULTI-POINT feature class, not a normal point feature class. Ie, each feature can be multiple points.

So I then used the "Multipart to Single part" tool to convert the feature class and creating points in the converted feature class worked normally as expected.

Really, this should be considered as a bug in ArcMap. Instead of silently failing to save what may be an unfinished "sketch", ArcMap should either "finish" the sketch and then save, or ask the user what to do. Or at the very least, produce an error message stating that the sketch was aborted because it was not finished. Silently destroying data the user has just created is a terrible behaviour for any application.

0

You could check to see if somehow they get sent to feature exclusion, that happened to me recently. Go to that layer's Properties > Display > Feature Exlusion at the bottom.

Sample Image

Restore all worked for me. Not sure if this is exactly your issue given the attribute part as well, but I thought it was worth mentioning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.