3

While using QGIS 3.x today I noticed that length values were not calculated and measured correctly on EPSG:32611. Calculating and measuring the same data on QGIS 2.18 latest LTR and 2.2 on EPSG:32611 does provide the correct length values.

I already tried on two different computers and the results are the same (wrong values on 3.x, correct values on 2.x). Also importing data generated on other sources (AutoCAD and Draftsight) and calculating length values provides the same result.

I know there are similar questions already asked but none have satisfactory answers. Is anyone else having similar issues and can provide help?

Steps to reproduce:

  1. Create new project on QGIS 3.x on EPSG:32611 (or maybe other UTMs).
  2. Create new shapefile line layer on EPSG:32611 (or maybe other UTMs).
  3. Create a line object and use advanced digitizing tools to force a length value (5).
  4. Use field calculator and/or measuring tool to get the length value of the newly created object.
  5. Repeat steps 1 through 4 on QGIS 2.x using the same EPSG code and compare length values.
  6. (optional) Import data from other sources on QGIS 3.x and 2.x, calculate/measure length values and compare.

EDIT: per Aaron request here is one of the similar questions already asked Field Calculator returning incorrect length and area values

  • I'm not seeing any similar questions, could you please provide a link to any similar questions? It may be useful to consolidate questions if they are on GIS SE. – Aaron Jun 26 '18 at 0:17
  • I included a link to a similar question. – display Jun 26 '18 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.