0

I'm trying to convert a polygon file to raster but when I execute the function I get this error message:

clement\cdq\landuse_mrc4. May be locked by another application. Failed to execute (polygonToRaster).

I've tried closing everything and doing it again but it still doesn't work... does anyone know what to do in this situation ?

  • Is the data on a shared drive? Is it possible someone else may be using the data at the same time? – Bjorn Jun 29 '18 at 19:26
  • If that is the error message they really need to improve their basic English! – Hornbydd Jun 29 '18 at 19:48
3

A lock commonly means that another application is accessing a database, and the ability to alter its structure, such as by adding or removing fields, is restricted. A common cause for a schema lock is displaying a dataset while trying to modify the dataset in another application.

Solution - If using multiple applications, check whether those applications might be accessing the same data.

I usually get locks when: - someone else is using the data - I have multiple programs looking at the data - the data is in my mxd multiple times - the data is being used in a service and the service hasn't been shut down

You can try looking at your database connections to identify where the multiple connections are coming from, and either disconnect them from there, or manually shut things down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.