2

I have just installed QGIS 3.2 on my Mac (over the top of 3.0.2) but it keeps crashing on start up -- before opening any window but after the splash screen is removed.

I have installed Python 3.6.6 and Qt 5.11.0 in the process of trying to fix this.

Update: I have now logged this as an issue on the bug tracker here.

I have appended a truncated crash report as it would have been sent to Apple. Quick summary is that the stack trace shows it dying from a segfault in Thread 0 which appeared to be trying to set the Title bar text.:

Process:               QGIS [90674]
Path:                  /Applications/QGIS3.app/Contents/MacOS/QGIS
Identifier:            org.qgis.qgis3
Version:               3.2.0 (3.2.0 [exported])
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           QGIS [90674]
User ID:               501

Date/Time:             2018-07-02 16:33:21.596 +1200
OS Version:            Mac OS X 10.13.5 (17F77)
Report Version:        12
Anonymous UUID:        BE9EB719-113B-804E-96AC-C6D8FB029D02


Time Awake Since Boot: 14000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000008
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

VM Regions Near 0x8:
--> 
    __TEXT                 0000000100bf1000-0000000101055000 [ 4496K] r-x/rwx SM=COW  /Applications/QGIS3.app/Contents/MacOS/QGIS

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   org.qt-project.QtWidgets        0x0000000105fdb3ed QAction::setText(QString const&) + 13
1   libqgis_app.3.2.0.dylib         0x00000001010fc641 QgisApp::changeEvent(QEvent*) + 89
2   org.qt-project.QtWidgets        0x000000010601e790 QWidget::event(QEvent*) + 144
3   org.qt-project.QtWidgets        0x000000010613e514 QMainWindow::event(QEvent*) + 1108
4   libqgis_app.3.2.0.dylib         0x00000001010b34f5 QgisApp::event(QEvent*) + 249
5   org.qt-project.QtWidgets        0x0000000105fe5792 QApplicationPrivate::notify_helper(QObject*, QEvent*) + 306
6   org.qt-project.QtWidgets        0x0000000105fe6aaf QApplication::notify(QObject*, QEvent*) + 383
7   org.qgis.qgis3_core             0x0000000102ec98b7 QgsApplication::notify(QObject*, QEvent*) + 93
8   org.qt-project.QtCore           0x00000001096bd32f QCoreApplication::notifyInternal2(QObject*, QEvent*) + 159
9   org.qt-project.QtWidgets        0x0000000106019ca2 QWidget::setWindowTitle(QString const&) + 482
10  libqgis_app.3.2.0.dylib         0x00000001010e55a0 setTitleBarText_(QWidget&) + 1315
11  org.qt-project.QtCore           0x00000001096edcdb QMetaObject::activate(QObject*, int, int, void**) + 2347
12  org.qgis.qgis3_core             0x000000010352ee92 QgsProject::isDirtyChanged(bool) + 64
13  org.qgis.qgis3_core             0x000000010307fa83 QgsProject::setSnappingConfig(QgsSnappingConfig const&) + 141
14  libqgis_app.3.2.0.dylib         0x0000000101253cb2 QgsSnappingWidget::QgsSnappingWidget(QgsProject*, QgsMapCanvas*, QWidget*) + 11058
15  libqgis_app.3.2.0.dylib         0x000000010109e3fd QgisApp::createToolBars() + 407
16  libqgis_app.3.2.0.dylib         0x0000000101096b8a QgisApp::functionProfile(void (QgisApp::*)(), QgisApp*, QString const&) + 62
17  libqgis_app.3.2.0.dylib         0x00000001010773be QgisApp::QgisApp(QSplashScreen*, bool, bool, QString const&, QString const&, QWidget*, QFlags) + 10652
18  org.qgis.qgis3                  0x0000000100c032d4 main + 20280
19  libdyld.dylib                   0x00007fff7116f015 start + 1

[ snip ]

Logical CPU:     2
Error Code:      0x00000004
Trap Number:     14


Binary Images:
       0x100bf1000 -        0x101054fff +org.qgis.qgis3 (3.2.0 - 3.2.0 [exported])  /Applications/QGIS3.app/Contents/MacOS/QGIS
       0x101061000 -        0x101064fff +org.qgis.qgis2_native (3.2.0 - qgis_native 3.2.0)  /Applications/QGIS3.app/Contents/Frameworks/qgis_native.framework/Versions/3.2/qgis_native
       0x101067000 -        0x1017f4ffb +libqgis_app.3.2.0.dylib (0)  /Applications/QGIS3.app/Contents/MacOS/lib/libqgis_app.3.2.0.dylib
       0x101b72000 -        0x101c2cff3 +libqwt.dylib (0)  /Applications/QGIS3.app/Contents/MacOS/lib/libqwt.dylib
       0x101c95000 -        0x101cdaff3 +org.qgis.qgis3_3d (3.2.0 - qgis_3d 3.2.0)  /Applications/QGIS3.app/Contents/Frameworks/qgis_3d.framework/Versions/3.2/qgis_3d
       0x101d0c000 -        0x101d2fffb +org.qt-project.QtSql (5.9 - 5.9.3)  /Applications/QGIS3.app/Contents/Frameworks/QtSql.framework/Versions/5/QtSql
       0x101d42000 -        0x101d46ffb +org.qt-project.QtConcurrent (5.9 - 5.9.3)  /Applications/QGIS3.app/Contents/Frameworks/QtConcurrent.framework/Versions/5/QtConcurrent

[snip]

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 5
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 888798
    thread_create: 0
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=495.8M resident=0K(0%) swapped_out_or_unallocated=495.8M(100%)
Writable regions: Total=203.8M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=203.8M(100%)

                                VIRTUAL   REGION 
REGION TYPE                        SIZE    COUNT (non-coalesced) 
===========                     =======  ======= 
Accelerate framework               256K        2 
Activity Tracing                   256K        2 
CG backing stores                 2876K        5 
CG image                            80K        4 
CoreAnimation                       20K        4 
CoreGraphics                         8K        2 
CoreImage                            8K        3 
CoreUI image data                  472K        7 
CoreUI image file                  180K        3 
Foundation                           4K        2 
Kernel Alloc Once                    8K        2 
MALLOC                           185.6M       50 
MALLOC guard page                   48K       11 
Memory Tag 242                      12K        2 
STACK GUARD                       56.0M       11 
Stack                             12.6M       11 
VM_ALLOCATE                        160K       15 
__DATA                            32.5M      348 
__FONT_DATA                          4K        2 
__LINKEDIT                       230.1M      104 
__TEXT                           265.7M      339 
__UNICODE                          560K        2 
mapped file                       50.2M       23 
shared memory                      632K       11 
===========                     =======  ======= 
TOTAL                            838.1M      941 


2

I've had the same kind of issue when upgrading to 3.2.0 and eventually got around it by removing (actually, renaming it) my settings directory to something else so it would get created from scratch. It is likely coming from a plugin going astray, but I had to get around it quickly and haven't investigated much more than that...

  • 1
    Bingo! :) and the settings are now in ~/Library/Application\ Support/QGIS/QGIS3/profiles/ rather than .qgisx/ – Russell Fulton Jul 3 '18 at 2:43
2

I've had the same issue on MacOS Sierra when upgraded to 3.2.0. After removing QGIS 3 profile and installed a fresh copy of QGIS 3.2.0 everything was fine until I have installed QuickMapServices plugin when started again to crash at launch. QuickMapServices was the only plugin, of all that I installed, that caused such behavior. This observation is based on the empirical trial and error method. Could there be a problem with this plugin?

  • I also had QuickMapSercives installed, so that ranks him up quite high on the list of potential suspects. – Julien Marchand Jul 4 '18 at 1:24
  • Me too :) I think we have a prime suspect ;) – Russell Fulton Jul 4 '18 at 1:44
  • According with the error message received at QGIS 3.2.0 start up on Win 7, "2018-07-04T17:17:52 WARNING Plugin quick_map_services : The plugin will be disabled because it crashed QGIS during last start up. Please report an issue and re-enable the plugin when the problem has been solved." it seems that the QuickMapServices plugin is responsible for start up crushing, even on Win version. – quercus Jul 4 '18 at 14:22
  • Once I had 3.2 up and running I was able to reinstall QMS and have QGIS continue to work even after restarts. – Russell Fulton Jul 4 '18 at 21:34
1

The crash report that opens gets sent to apple automatically, but that won't really help you get QGIS running.

On your mac, open a new finder window, and hit the Applications button on the left bar. Scroll down to Utilities, and open the app Console. The crash log you saw should be listed under the User Reports section.

On the left bar, click on system log, and try a search for qgis. Also, click on /var/log and in the pane that appears to the right click on install.log. If you had any errors at install, they may show up here.

Any errors you see in addition to the crash report from above will hopefully provide a good start towards tracking down the problem. Feel free to post them here if you want more help tracking it down...these things aren't always real easy to make sense of.

  • I should have trolled through the system.log before posting! Not that it revealed much :( It died of a segfault which appeared to be caught by launchd so there was no useful info. Since it appeared to die as it was bringing up the GUI and I knew there was another bug that I had reported that was fixed in the latest version of Qt (5.11.0) I installed that and it fixed the start up problem. – Russell Fulton Jul 2 '18 at 4:22
  • Dam! spoke too soon. I reinstalled from the wrong dmg ( 3.0 .2 rather than 3.2.0). Problem is not solved. I will attach the crash report to see it someone can use it to shed some light. It does appear to be crashing in Qt. I'lll update the main question. – Russell Fulton Jul 2 '18 at 4:37
0

I've just had QGIS crash on me and I was also unable to reopen it. When I tried reopening it continually crashed. I had to uninstall and then reinstall a clean copy of QGIS 3.2.

When uninstalling i did a search in my library folder for all QGIS related files and removed all of them first. Also empty the trash before you install the clean copy. No need to remove Python or GDAL as these seem to be fine.

All is working fine now, although I do need to reinstall plugins and set up server connections once again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.