2

I have tried to use the v.what.rast tool in Qgis 3.2 to extract elevation values ​​from an image of the alos-palsar sensor. And it does not generate the column with the elevation data. I create the elevation column previously to be filled by the tool. In terms of the fields, it is mentioned in the GRASS v.what.rast help page that the field type must be numeric:

Integer, Float, Double

So you will need to create a numeric field, not string, in order to store the results.

I follow the steps of the tool in Qgis and I always get the table of the new empty shapefile.

Why is this problem.

enter image description here

I prepare the tool. and I run the algorithm

enter image description here

This is the result I get ... What is the problem?

enter image description here

WARNING: Missing column name

Update vector attributes ...

0..WARNING: There is no record for category 3 in the table

14..WARNING: There is no record for category 2 in the table

28..WARNING: There is no record for category 4 in the table

42..WARNING: There is no record for category 1 in the table

57..WARNING: There is no record for category 5 in the table

71..WARNING: There is no record for category 0 in the table

85..WARNING: There is no record for category 6 in the table

100

v.what.rast complete. 0 updated records.

enter image description here

  • So you have a shapefile with some points in the same coordinate system as the ALOS data (WGS84, lon/at) ? – Micha Jul 3 '18 at 20:28
  • The Alos-Palsar image, and the shapefile of points, have the same EPSG coordinate system: 32619 (WGS84 / UTM19N – Pedro Javier Jul 3 '18 at 22:21
  • Do you have the possibility to run this directly in GRASS, in order to determine if the problem is with the QGIS Processing algorithm definition? – Micha Jul 5 '18 at 12:23
  • in grass there are no problems. The problem is the algorithm in Qgis ... it does not finish overwriting the data in the output table – Pedro Javier Jul 9 '18 at 21:12
  • Might be worth posting this directly to the Processing plugin issue tracker. – Micha Jul 10 '18 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.