2

I am using "Point Sampling Tool" in QGIS 3.2 to obtain values from a raster file to a point layer.

After selecting the layer with the points, the values to get values from, and defining the Output point vector layer, I run the process and I get this error:

enter image description here

I already have all layers with the same projection, and the point layer is a shapefile. I think the problem could be during the process of saving the new shapefile because it seems that the values were obtained (see bellow in the image, "Status: Processing point 180 out of 180").

Update: I tried the same procedure but this time with QGIS 2.18, and I get a similar error: "The new layer seems to be created, but is invalid. It won't be loaded"

(which ends up being the same problem as this one: QGIS Point Sampling Tool: Invalid layer)

Does anyone know how to solve this error?

2

I believe I found the answer, it is quite simple.

The problem seems to be in the place where the file is being saved. So, the only thing that needs to be done is change the folder destination for the file. The standard folder will not work and will provide this error!

(I don't know why this is happening but this solution worked for me!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.