1

I would like to use the tool "v.rectify" from GRASS in my plugin, but when I call it, it continues to say that "ERROR: Required parameter 'output' not set", although this parameter is set. I think this is a bug. I run the tool with the following parameters:

{ '-3' : False, '-b' : False, '-o' : False, 'GRASS_MIN_AREA_PARAMETER' : 0.0001,
'GRASS_OUTPUT_TYPE_PARAMETER' : 1, 'GRASS_REGION_PARAMETER' : None,
'GRASS_SNAP_TOLERANCE_PARAMETER' : -1, 'GRASS_VECTOR_DSCO' : '','GRASS_VECTOR_LCO' : '',
'inline_points' : '', 'input' : 'F:/Study/6_semester/manufacturing_practice/Results/
ClipProject.shp', 'order' : 2, 'output' : 'rectified_test', 'points' : 'F:/Study/6_semester/
manufacturing_practice/Work/LinkTable_fixed.txt', 'rmsfile' : 'F:/Users/Ram1L/AppData/Local/
Temp/processing_13eee64d26b245df93f2fdc2e933ecd0/b7cd4c655ce04008af2d038b81108a60/rmsfile.txt',
'separator' : 'pipe' }

I tried to use the tool in the GRASS itself with the same parameters and it works. Also tried many times to change the input parameters. QGIS version - 3.2.0-Bonn, GRASS version - 7.4.1, OS - Windows 8.1. Link to the log of tool - https://pastebin.com/tFfLcrNF. Other tool from GRASS section in processing toolbox v.buffer works fine. Sorry for bad english

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.