I have imported a layer into my map to show the location of towns/cities. However I had to set graduated styling so that only cities over a certain population show.

I now want to label the ones that show but if I add labels all of the labels show rather than just the ones which I want to appear in my map.

I think I can solve the problem using Expression-based labeling. Following this tutorial: https://underdark.wordpress.com/2011/10/27/expression-based-labeling-for-qgis/

But I can't find the settings. When I go into the labelling options I see this:

Label options

What do I do next? Any help would be amazing.

1 Answer 1


Click the little ... icon :)

Maybe I should rename it to "expression..."

  • 3
    Thanks a lot for the reply and on the IRC as well. I would say that it is not all that obvious to a new user. A change of labelling might be helpful.
    – user8575
    Jul 4, 2012 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.